Bug 51812 - should place script in /etc/cron.d instead of modifying /etc/crontab
should place script in /etc/cron.d instead of modifying /etc/crontab
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: mrtg (Show other bugs)
8.0
i386 Linux
medium Severity low
: ---
: ---
Assigned To: Nalin Dahyabhai
David Lawrence
:
: 62970 64555 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-08-15 10:35 EDT by Mirko Zeibig
Modified: 2007-04-18 12:35 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-08-17 02:41:00 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch to RHL80 mrtg.spec to move cron work to separate file in /etc/cron.d (2.07 KB, patch)
2003-01-11 08:32 EST, Bishop Clark
no flags Details | Diff
Patch to RHL73 mrtg.spec to move cron work to separate file in /etc/cron.d (2.06 KB, patch)
2003-01-11 08:36 EST, Bishop Clark
no flags Details | Diff
Patch to RHL72 mrtg.spec to move cron work to separate file in /etc/cron.d (2.60 KB, patch)
2003-01-11 08:37 EST, Bishop Clark
no flags Details | Diff

  None (edit)
Description Mirko Zeibig 2001-08-15 10:35:51 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.3) Gecko/20010802

Description of problem:
Instead of fiddling around with /etc/crontab sth. like:

[root@heulsuse bin]# o /etc/cron.d/mrtg 
0-59/5 * * * * root /usr/bin/mrtg /etc/mrtg/mrtg.cfg

should be installed.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.None
	

Additional info:
Comment 1 Joe Orton 2002-06-14 10:48:01 EDT
*** Bug 62970 has been marked as a duplicate of this bug. ***
Comment 2 Joe Orton 2002-06-14 10:49:09 EDT
*** Bug 64555 has been marked as a duplicate of this bug. ***
Comment 3 Binand Sethumadhavan 2002-07-08 02:10:00 EDT
Is it possible for MRTG package to ship with an initscript for those of us 
who'd like to run it as a daemon? The default MRTG redhat ships makes the PID 
file in /etc/mrtg/mrtg.pid (when run as daemon). This should go to /var/run as 
well.
Comment 4 Bishop Clark 2002-12-14 08:11:39 EST
Hey Nalin,

This bug's been kicking about for a good year or so.  I know that you're super
busy, but can I pick this one up, roll some modified packages and feed you some
patches?

It's a one-banana problem, really, and I wouldn't mind taking this one. 
Considering I have RHL 6.2-8.0 here, I may have a unique opportunity 8-)

Let me know.
Comment 5 Bishop Clark 2003-01-11 08:32:51 EST
Created attachment 89300 [details]
Patch to RHL80 mrtg.spec to move cron work to separate file in /etc/cron.d

Patch to RHL80 mrtg.spec to move cron work to separate file in /etc/cron.d
Comment 6 Bishop Clark 2003-01-11 08:36:33 EST
Created attachment 89301 [details]
Patch to RHL73 mrtg.spec to move cron work to separate file in /etc/cron.d

Patch to RHL73 mrtg.spec to move cron work to separate file in /etc/cron.d
Comment 7 Bishop Clark 2003-01-11 08:37:33 EST
Created attachment 89302 [details]
Patch to RHL72 mrtg.spec to move cron work to separate file in /etc/cron.d

Patch to RHL72 mrtg.spec to move cron work to separate file in /etc/cron.d
Comment 8 Bishop Clark 2003-01-11 08:40:57 EST
Release Notes on the patch:

 - The change causes the mrtg package to ship an /etc/cron.d/mrtg file.
 - I also noticed that literal/macro use in the SPEC wasn't uniform 
   and corrected that for one macro.
 - the RHL80 patch file is missing one mod:  I changed the %release to 9
   when it successfully built;  obviously I shipped the older diff, and I 
   didn't feel like spamming everyone with a new copy.  

All of these (S)RPMs are available at
http://www.platypus.bc.ca/~bishop/software/mrtg-rh/

Enjoy.  Test.  Share.  Etc.
Comment 9 Miloslav Trmač 2004-08-16 16:47:16 EDT
/etc/cron.d is used in FC2 mrtg-2.10.5-3.

Note You need to log in before you can comment on or make changes to this bug.