Bug 518383 - condor-ec2-enhanced conflicts with condor-low-latency
Summary: condor-ec2-enhanced conflicts with condor-low-latency
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Enterprise MRG
Classification: Red Hat
Component: distribution
Version: Development
Hardware: All
OS: Linux
low
medium
Target Milestone: 1.2
: ---
Assignee: mrg-program-list
QA Contact: MRG Quality Engineering
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-08-20 07:37 UTC by Martin Kudlej
Modified: 2009-08-20 13:53 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-08-20 13:53:35 UTC


Attachments (Terms of Use)

Description Martin Kudlej 2009-08-20 07:37:29 UTC
Description of problem:
[root@mrg-qe-01 ~]# yum --enablerepo=mrg-rhel5-devel install  condor-low-latency condor-ec2-enhanced condor-ec2-enhanced-hooks
Loaded plugins: rhnplugin, security
This system is not registered with RHN.
RHN support will be disabled.
Setting up Install Process
Parsing package install arguments
Resolving Dependencies
--> Running transaction check
---> Package condor-ec2-enhanced.noarch 0:1.0-17.el5 set to be updated
--> Processing Dependency: python-boto >= 1.7a for package: condor-ec2-enhanced
--> Processing Dependency: condor >= 7.0.2-4 for package: condor-ec2-enhanced
--> Processing Dependency: condor-job-hooks for package: condor-ec2-enhanced
--> Processing Dependency: python-condor-job-hooks-common for package: condor-ec2-enhanced
--> Processing Dependency: python-condor-ec2-enhanced-hooks-common for package: condor-ec2-enhanced
---> Package condor-ec2-enhanced-hooks.noarch 0:1.0-19.el5 set to be updated
---> Package condor-low-latency.noarch 0:1.0-19.el5 set to be updated
--> Running transaction check
---> Package python-condor-job-hooks-common.noarch 0:1.0-12.el5 set to be updated
---> Package condor.i386 0:7.3.2-0.4.el5 set to be updated
--> Processing Dependency: gsoap >= 2.7.12 for package: condor
--> Processing Dependency: libgsoapssl++.so.0 for package: condor
--> Processing Dependency: libclassad_ns.so.0 for package: condor
--> Processing Dependency: libclassad.so.0 for package: condor
---> Package python-boto.noarch 0:1.7a-1.el5 set to be updated
---> Package python-condor-ec2-enhanced-hooks-common.noarch 0:1.0-19.el5 set to be updated
---> Package condor-job-hooks.noarch 0:1.0-12.el5 set to be updated
--> Running transaction check
---> Package classads.i386 0:1.0.2-1.el5 set to be updated
---> Package gsoap.i386 0:2.7.12-2.el5 set to be updated
--> Processing Conflict: condor-low-latency conflicts condor-ec2-enhanced
--> Processing Conflict: condor-ec2-enhanced conflicts condor-low-latency
--> Finished Dependency Resolution
condor-ec2-enhanced-1.0-17.el5.noarch from mrg-rhel5-devel has depsolving problems
  --> condor-ec2-enhanced conflicts with condor-low-latency
condor-low-latency-1.0-19.el5.noarch from mrg-rhel5-devel has depsolving problems
  --> condor-low-latency conflicts with condor-ec2-enhanced
Error: condor-low-latency conflicts with condor-ec2-enhanced
Error: condor-ec2-enhanced conflicts with condor-low-latency



Version-Release number of selected component (if applicable):
MRG devel repo.
[mrg-rhel5-devel]
name=Devel MRG packages from {download.devel|yum.engineering|porkchop}.../dist-5E-mrg-devel
baseurl=http://download.devel.redhat.com/rel-eng/repos/dist-5E-mrg-devel/$basearch
        http://yum.engineering.redhat.com/rel-eng/repos/dist-5E-mrg-devel/$basearch
        http://porkchop.redhat.com/rel-eng/repos/dist-5E-mrg-devel/$basearch


How reproducible:
100%

  
Actual results:
There is conflict between packages.

Expected results:
No conflicts.

Comment 1 Robert Rati 2009-08-20 13:53:35 UTC
This is intended.  The low-latency daemon and ec2e daemons can't both function on a single machine because the job hooks condor uses to talk to them can only talk to 1 daemon.


Note You need to log in before you can comment on or make changes to this bug.