Bug 518396 - EnableOpenGPG option in abrt.conf takes no effect
Summary: EnableOpenGPG option in abrt.conf takes no effect
Keywords:
Status: CLOSED NEXTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: abrt
Version: rawhide
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Jiri Moskovcak
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-08-20 09:14 UTC by Eryu Guan
Modified: 2015-02-01 22:48 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-08-20 15:45:33 UTC


Attachments (Terms of Use)

Description Eryu Guan 2009-08-20 09:14:22 UTC
Description of problem:

abrt detects crashes of programs from unsigned packages when EnableOpenGPG is set to yes

Version-Release number of selected component (if applicable):

abrt-0.0.7.1-1.fc12

How reproducible:

100%

Steps to Reproduce:
1. Download a 3rd party package, eg. 
# wget http://dl_dir.qq.com/linuxqq/linuxqq-v1.0.2-beta1.i386.rpm

2. Install the downloaded rpm with root privilege
# rpm -ivh linuxqq-v1.0.2-beta1.i386.rpm

3. Run qq with non-privilege user from command line and take down its pid
$ qq&
[1] 7359
$ ps -ef | grep qq
liveuser 7359 1782 0 17:08 pts/0 00:00:00 /bin/sh /usr/bin/qq
liveuser 7360 7356 0 17:08 pts/0 00:00:00 ./qq

4. Make sure the "EnableOpenGPG" option is set to "yes" in /etc/abrt/abrt.conf. 

5. Send SIGSEGV to qq
$ kill -SIGSEGV 7360
  
Actual results:
abrt-applet pops up a notification says qq crashed. abrt-gui lists an item about this crash

Expected results:
abrt ignores this crash

Additional info:

Comment 1 Zdenek Prikryl 2009-08-20 09:29:40 UTC
This is the old option. We forgot to update it to new one OpenGPGCheck in default abrt.conf. Can you try reproduce this bug with new option? Thanks.

Comment 2 Kamil Páral 2009-08-20 09:38:29 UTC
I have replaced EnableOpenGPG with OpenGPGCheck and when set to "no", it handles all crashes (which is ok). When set to "yes", it does not handle any crash, neither from signed nor from unsigned package.

Comment 3 Eryu Guan 2009-08-20 09:48:36 UTC
(In reply to comment #2)
> I have replaced EnableOpenGPG with OpenGPGCheck and when set to "no", it
> handles all crashes (which is ok). When set to "yes", it does not handle any
> crash, neither from signed nor from unsigned package.  

I got the same problem.
I am running LiveCD in VirtualBox.

Comment 4 Kamil Páral 2009-08-20 10:36:09 UTC
It seems that this option can be tested on Fedora 11 only, because Rawhide (and thus the provided LiveCD) does not contain properly signed packages. Have anyone noticed bad behaviour on Fedora 11?

Comment 5 Michal Nowak 2009-08-20 11:24:07 UTC
OpenGPGCheck = yes

with current Git on F-11 does *not* work for me. I confirm comment #2.

Comment 6 Jiri Koten 2009-08-20 13:12:57 UTC
+1 comment#2 on F11

Comment 7 Zdenek Prikryl 2009-08-20 15:45:33 UTC
it should be fixed in a git now.


Note You need to log in before you can comment on or make changes to this bug.