Bug 518428 - Spammed with many simultaneous PackageKit 'Distribution upgrades available' notifications after yumBackend get-updates unwedged
Summary: Spammed with many simultaneous PackageKit 'Distribution upgrades available' n...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: PackageKit
Version: 10
Hardware: i386
OS: Linux
low
high
Target Milestone: ---
Assignee: Richard Hughes
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-08-20 11:44 UTC by Dick Porter
Modified: 2009-08-21 13:35 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-08-21 13:35:36 UTC


Attachments (Terms of Use)

Description Dick Porter 2009-08-20 11:44:18 UTC
Description of problem:

I noticed the 'YumBackend.py get-updates' process had wedged when a yum install told me it was blocking on a 38 day old process.  I killed the YumBackend process, and a new one was respawned that noticed there is a distribution upgrade available.

This then proceeded to notify me (54 times at once so far, and no end in sight), causing the Xorg process to consume close to 100% CPU and the system therefore unresponsive.

I'd rather not reboot to clear this notification backlog as I have a large amount of work state that would need to be recreated if I did.



Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. Not update to Fedora 11
2. Wedge the yumBackend.py process that checks for updates
3. Wait 5 or 6 weeks
4. Kill the yumBackend.py process
5. Spend several hours clicking on dozens of simultaneous notifications while trying to preserve work
  
Actual results:

Dozens of simultaneous notifications


Expected results:

One notification


Additional info:

Comment 1 Richard Hughes 2009-08-20 15:34:37 UTC
Difficult to reproduce, but I think I can fudge something.

Comment 2 Richard Hughes 2009-08-21 13:01:17 UTC
Hmm, I've been trying for a little while, but I can't reproduce this on F11 or rawhide. Does this still happen in F11?

Comment 3 Dick Porter 2009-08-21 13:05:17 UTC
No idea, I'm not running F11 yet - and even if I were it's a bit difficult to trigger in normal use :)

Comment 4 Richard Hughes 2009-08-21 13:35:36 UTC
Right, I've reviewed the codebase we use in F11 and rawhide, and there's no way we can send multiple requests in a short amount of time. I'll close this one for now, but if you can reproduce with F11, I would be interested. Note., F11 seems to get itself wedged a lot less than F10!


Note You need to log in before you can comment on or make changes to this bug.