Bug 518459 - cannot use # in bugzilla password
Summary: cannot use # in bugzilla password
Keywords:
Status: CLOSED NEXTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: abrt
Version: rawhide
Hardware: All
OS: Linux
high
high
Target Milestone: ---
Assignee: Jiri Moskovcak
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-08-20 13:53 UTC by Vladimir Benes
Modified: 2015-02-01 22:48 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-08-20 14:13:36 UTC


Attachments (Terms of Use)

Description Vladimir Benes 2009-08-20 13:53:53 UTC
Description of problem:
I cannot use # (possibly some other special characters) as this seems to be parsed out as a comment as password is stored in plain text 

Version-Release number of selected component (if applicable):
abrt-0.0.7.1-1

How reproducible:
100%

Steps to Reproduce:
1.use bz password containing # and store it via preferences bz dialog
2.report any bug
3.
  
Actual results:
cannot report as login fails

Expected results:
can login without errors

Additional info:
you can also see this error when editing already stored #containg password in preferences bz dialog (# and following character are not showed in hidden password)

Comment 1 Zdenek Prikryl 2009-08-20 14:13:36 UTC
# makrs comment's begin. So, from now comment can be only whole line, which starts with #. Otherwise # is not interpreted as comment's begin.


Note You need to log in before you can comment on or make changes to this bug.