Bug 518485 - [RFE] ability of communication condor hooks with more than one daemon
Summary: [RFE] ability of communication condor hooks with more than one daemon
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Enterprise MRG
Classification: Red Hat
Component: condor
Version: 1.1
Hardware: All
OS: Linux
low
low
Target Milestone: 3.0
: ---
Assignee: Matthew Farrellee
QA Contact: Martin Kudlej
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-08-20 15:21 UTC by Martin Kudlej
Modified: 2013-01-08 19:09 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-01-08 19:09:03 UTC


Attachments (Terms of Use)

Description Martin Kudlej 2009-08-20 15:21:39 UTC
Description of problem:
see https://bugzilla.redhat.com/show_bug.cgi?id=518383#c1

Actual results:
There are condor job hooks which are able to communicate with just one daemon (ec2, low-latency).

Expected results:
Condor job hooks work with more than one daemon in the same time.

Additional info:

Comment 1 Matthew Farrellee 2009-10-22 15:23:32 UTC
From the Condor side, per slot hooks are available. This allows for SLOT1 to call hooks that contact carod while SLOT2 calls hooks to access caroniad. The issue is the hooks in both cases are the same script and lookup which daemon to contact via condor_config_val of JOB_HOOK_IP and JOB_HOOK_PORT. The script needs to know the context in which it is being invoked.

The hooks should use their invocation context to lookup the proper JOB_HOOK_IP and JOB_HOOK_PORT.

Some context is already provided with the hook keyword.

For all hooks, except fetch, the hook keyword is present in the job ad. For the fetch hook the slot identify is present.

The hooks could do a two step lookup for the fetch hook, or the startd could be updated to include the hook keyword in the slot ad.

Comment 2 Matthew Farrellee 2013-01-08 19:09:03 UTC
Reopen when requirement exists.


Note You need to log in before you can comment on or make changes to this bug.