Bug 518690 - fwbackups 1.43.3rc3 fails automatic backup
Summary: fwbackups 1.43.3rc3 fails automatic backup
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: fwbackups
Version: 10
Hardware: x86_64
OS: Linux
low
medium
Target Milestone: ---
Assignee: Stewart Adam
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-08-21 17:17 UTC by Davide Rondini
Modified: 2009-08-31 23:37 UTC (History)
1 user (show)

Fixed In Version: 1.43.3-0.6.rc4.fc10
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-08-31 23:37:35 UTC


Attachments (Terms of Use)

Description Davide Rondini 2009-08-21 17:17:01 UTC
Description of problem:
After last update of fwbackups, my automatic daily backup set stopped to work. Every time cron job is activated, I receive a system mail reporting this error:

Cron <davide@quad> fwbackups-run -l 'Home Davide'

Traceback (most recent call last):
  File "/usr/bin/fwbackups-run", line 25, in <module>
    from fwbackups.i18n import _
ImportError: No module named fwbackups.i18n

The error started since last update some days ago, fwbackups worked fine before.
If I start the program and do the backup manually, everything wokrs fine, and the log window confirms that automatic backup has not been done.

Version-Release number of selected component (if applicable):
Name       : fwbackups
Arch       : noarch
Version    : 1.43.3
Release    : 0.5.rc3.fc10
Repo       : installed
From repo  : updates


How reproducible:
Always after update

Steps to Reproduce:
1. Create a backup set associated to a cron job
2. Update to latest version of fwbackups
3. Wait for the planned backup time
  
Actual results:


Expected results:


Additional info:

Comment 1 Stewart Adam 2009-08-21 19:46:33 UTC
Thanks for reporting this, I'll fix it tonight. In the mean time, symlinking /usr/share/fwbackups to /usr/lib/python2.6/site-packages should workaround the problem.

Comment 2 Stewart Adam 2009-08-21 19:47:14 UTC
Erm, just to be clear I mean symlink the /usr/share/fwbackups directory into the /usr/lib/python2.6/site-packages, creating /usr/lib/python2.6/site-packages/fwbackups.

Comment 3 Davide Rondini 2009-08-22 16:34:02 UTC
I tried linking as you said both in /usr/lib/python2.5/site-package or in /usr/lib64/python2.5/site-package, but the problem wasn't fixed.

I have Python 2.5.2 (standard Feroda 10 Package), I don't know if this matters...

Comment 4 Stewart Adam 2009-08-22 20:58:23 UTC
I've just built 1.43.3rc4, so you can remove the symlink(s) and grab it from updates-testing soon.

Comment 5 Fedora Update System 2009-08-22 21:04:47 UTC
fwbackups-1.43.3-0.6.rc4.fc10 has been submitted as an update for Fedora 10.
http://admin.fedoraproject.org/updates/fwbackups-1.43.3-0.6.rc4.fc10

Comment 6 Fedora Update System 2009-08-25 04:47:05 UTC
fwbackups-1.43.3-0.6.rc4.fc10 has been pushed to the Fedora 10 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update fwbackups'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F10/FEDORA-2009-8976

Comment 7 Davide Rondini 2009-08-29 16:57:59 UTC
Ok, installing the update fixes the problem for me.

Comment 8 Fedora Update System 2009-08-31 23:37:30 UTC
fwbackups-1.43.3-0.6.rc4.fc10 has been pushed to the Fedora 10 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.