Bug 51874 - With demand dialling, ifup/ifdown ppp0 does not function
With demand dialling, ifup/ifdown ppp0 does not function
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: initscripts (Show other bugs)
7.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-08-16 05:41 EDT by Need Real Name
Modified: 2014-03-16 22:22 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-06-17 11:57:15 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patched ifdown-ppp (read my comment). NOTE: I don't know if it's good. (1.08 KB, text/x-sh)
2002-03-29 20:13 EST, Boris de Laage
no flags Details

  None (edit)
Description Need Real Name 2001-08-16 05:41:28 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.75 [en] (X11; U; Linux 2.4.7 i686)

Description of problem:
System is compiled Kernel 2.4.7 on an initially RH7.0 distro, various
packages upgraded as required from 7.1 distro. 

My problem is that  with the configuration for the ppp0 interface set
for demand dialing (DEMAND=yes,  in
/etc/sysconfig/network-scripts/ifcfg-ppp0 as I have attached) if I call
'ifup ppp0'  and then if the 'ifdown ppp0' is run prior to an actual dial
and connection the ppp0 device does not seem to be shutdown properly.  Some
defunct processes are listed in the 'ps -ax' list.

Note this also occurs when I start the device using rp3 through the Gnome
desktop.

Subsequent 'ifup ppp0' requests seem to work ok but since ppp0 was not
shut down properly the new connections are on new devices ppp1, ppp2 or
more.   Rerunning 'ifdown ppp0' will not flush the spurious devices from
the system.

I have also seen a similar effect when the connection has failed due
for example to the modum having been switched off to break a connection.

Running ifconfig or checking /proc/sys/net/ipv4/conf/  shows these spurious
connections listed.

On the other hand, if there was an intervening connection to the internet,
ifdown cleans everything up nicely.



Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. setup for demand dialling
2. /sbin/ifup ppp0 then shortly after...
3. /sbin/ifdown ppp0
	

Expected Results:  all pppX devices closed

Additional info:

/etc/sysconfig/network-scripts/ifcfg-ppp0  is:

DEVICE=ppp0
NAME=IHUG2
WVDIALSECT=IHUG2
MODEMPORT=/dev/ttyS1
LINESPEED=115200
PAPNAME=douggray
USERCTL=true
ONBOOT=no
PERSIST=no
DEFROUTE=yes
PEERDNS=yes
DEMAND=yes
IDLETIMEOUT=600
BOOTPROTO=none
Comment 1 Need Real Name 2001-08-16 08:49:04 EDT
Forgot to mention: initscripts-5.83-1 in use
Comment 2 Boris de Laage 2002-03-29 20:11:12 EST
I had a similar problem: my ADSL link didn't go down properly, and that caused
problems with the remote server (15 minutes before re-connexion, ...).
I think that's because ifdown-ppp doesn't read the ifcfg-pppX file. I added
'need_config' to have ifdown-ppp reading that file and now it runs well;

here is the diff:
[boris@arthemisia network-scripts]$ diff ifdown-ppp-new ifdown-ppp
8d7
< need_config
Comment 3 Boris de Laage 2002-03-29 20:13:39 EST
Created attachment 51432 [details]
patched ifdown-ppp (read my comment). NOTE: I don't know if it's good.
Comment 4 Göran Uddeborg 2003-06-17 08:30:59 EDT
There has been work on demand dialing PPP lines.  It works for me with the most
recent releases.  Does anybody else still have this problem?  Otherwise maybe we
(reporter or Red Hat I guess) could do resolve/currentrelease?
Comment 5 Bill Nottingham 2003-06-17 11:57:15 EDT
Please do try with current releases; there's definitely been fixes since 7.0.

Note You need to log in before you can comment on or make changes to this bug.