Bug 518769 - anaconda hangs writing changes to disk
anaconda hangs writing changes to disk
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: lvm2 (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Milan Broz
Fedora Extras Quality Assurance
:
: 519368 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-08-22 12:55 EDT by Riku Seppala
Modified: 2013-02-28 23:07 EST (History)
16 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-08-25 14:31:10 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
anaconda.log (32.74 KB, text/plain)
2009-08-22 12:55 EDT, Riku Seppala
no flags Details
program.log (9.73 KB, text/plain)
2009-08-22 12:56 EDT, Riku Seppala
no flags Details
storage.log (49.20 KB, text/plain)
2009-08-22 12:56 EDT, Riku Seppala
no flags Details
syslog (43.26 KB, text/plain)
2009-08-22 12:57 EDT, Riku Seppala
no flags Details
ps -ef (5.44 KB, text/plain)
2009-08-24 10:34 EDT, Riku Seppala
no flags Details
strace of lvm pvcreate (64.45 KB, text/plain)
2009-08-25 11:36 EDT, Chris Lumens
no flags Details

  None (edit)
Description Riku Seppala 2009-08-22 12:55:02 EDT
Created attachment 358311 [details]
anaconda.log

Trying to install rawhide 20090822. Anaconda has been writing changes to disk about 30 minutes now. I see no hard disk activity.
Comment 1 Riku Seppala 2009-08-22 12:56:21 EDT
Created attachment 358312 [details]
program.log
Comment 2 Riku Seppala 2009-08-22 12:56:47 EDT
Created attachment 358313 [details]
storage.log
Comment 3 Riku Seppala 2009-08-22 12:57:08 EDT
Created attachment 358314 [details]
syslog
Comment 4 Chris Lumens 2009-08-24 10:12:34 EDT
Can you attach the output of ps -ef from tty2 to this bug report?  I wonder if you have any hung LVM processes.  I saw that the other day but had no reliable reproducer.
Comment 5 Riku Seppala 2009-08-24 10:34:25 EDT
Created attachment 358467 [details]
ps -ef
Comment 6 Chris Lumens 2009-08-25 11:36:54 EDT
Created attachment 358589 [details]
strace of lvm pvcreate

Yep, I was able to reproduce this again today and this time caught the strace output.  Looks like pvcreate is caught in a loop to me.
Comment 7 Milan Broz 2009-08-25 14:31:10 EDT
Yes, there was bug in pvcreate, fixed in last lvm2 rawhide build, lvm2-2.02.51-3.
Comment 8 Martin Banas 2009-08-26 07:46:52 EDT
*** Bug 519368 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.