Bug 518771 - setroubleshoot: SELinux is preventing slim (xdm_t) "unlink" var_run_t.
Summary: setroubleshoot: SELinux is preventing slim (xdm_t) "unlink" var_run_t.
Keywords:
Status: CLOSED DUPLICATE of bug 518068
Alias: None
Product: Fedora
Classification: Fedora
Component: slim
Version: rawhide
Hardware: x86_64
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Lorenzo Villani
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: setroubleshoot_trace_hash:6d676b75dbe...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-08-22 17:23 UTC by yunus
Modified: 2009-10-10 12:36 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-10-10 12:36:22 UTC


Attachments (Terms of Use)

Description yunus 2009-08-22 17:23:45 UTC
The following was filed automatically by setroubleshoot:

Summary:

SELinux is preventing slim (xdm_t) "unlink" var_run_t.

Detailed Description:

SELinux denied access requested by slim. It is not expected that this access is
required by slim and this access may signal an intrusion attempt. It is also
possible that the specific version or configuration of the application is
causing it to require additional access.

Allowing Access:

You can generate a local policy module to allow this access - see FAQ
(http://fedora.redhat.com/docs/selinux-faq-fc5/#id2961385) Please file a bug
report (http://bugzilla.redhat.com/bugzilla/enter_bug.cgi) against this package.

Additional Information:

Source Context                system_u:system_r:xdm_t:s0-s0:c0.c1023
Target Context                system_u:object_r:var_run_t:s0
Target Objects                slim.auth [ file ]
Source                        slim
Source Path                   /usr/bin/slim
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           slim-1.3.1-7.fc12
Target RPM Packages           
Policy RPM                    selinux-policy-3.6.26-8.fc12
Selinux Enabled               True
Policy Type                   targeted
MLS Enabled                   True
Enforcing Mode                Enforcing
Plugin Name                   catchall
Host Name                     (removed)
Platform                      Linux (removed)
                              2.6.31-0.125.4.2.rc5.git2.fc12.x86_64 #1 SMP Tue
                              Aug 11 21:00:45 EDT 2009 x86_64 x86_64
Alert Count                   2
First Seen                    Sun 23 Aug 2009 02:20:18 AM EDT
Last Seen                     Sun 23 Aug 2009 02:24:24 AM EDT
Local ID                      b119863e-551b-456c-9308-e3965f243e33
Line Numbers                  

Raw Audit Messages            

node=(removed) type=AVC msg=audit(1251008664.422:25980): avc:  denied  { unlink } for  pid=2586 comm="slim" name="slim.auth" dev=dm-0 ino=67558 scontext=system_u:system_r:xdm_t:s0-s0:c0.c1023 tcontext=system_u:object_r:var_run_t:s0 tclass=file

node=(removed) type=SYSCALL msg=audit(1251008664.422:25980): arch=c000003e syscall=87 success=no exit=-13 a0=1f7e848 a1=0 a2=0 a3=7ffff5b44f00 items=0 ppid=1 pid=2586 auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=4294967295 comm="slim" exe="/usr/bin/slim" subj=system_u:system_r:xdm_t:s0-s0:c0.c1023 key=(null)


audit2allow suggests:

#============= xdm_t ==============
allow xdm_t var_run_t:file unlink;

Comment 1 Huub Schaeks 2009-08-30 12:00:55 UTC
Have a look at this

https://bugzilla.redhat.com/show_bug.cgi?id=518068

bug; I think that should help.

Comment 2 Lorenzo Villani 2009-10-10 12:36:22 UTC
This bug is related to #518068. Closing.

*** This bug has been marked as a duplicate of bug 518068 ***


Note You need to log in before you can comment on or make changes to this bug.