Bug 51879 - NFS mount failure (incl. 'bad nfs status' kernel msg)
NFS mount failure (incl. 'bad nfs status' kernel msg)
Status: CLOSED WORKSFORME
Product: Red Hat Public Beta
Classification: Retired
Component: nfs-utils (Show other bugs)
roswell
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Pete Zaitcev
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-08-16 10:01 EDT by Need Real Name
Modified: 2007-04-18 12:35 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-08-17 16:30:35 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2001-08-16 10:01:33 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.75 [en] (X11; U; Linux 2.2.5-22 i686)

Description of problem:
Using RHL 7.2beta, unable to mount NFS volumes.  In /var/log/messages, amd
says it "cannot locate portmapper" on the nfs-server, and the kernel
complains about a "bad nfs status return value".

Version-Release number of selected component (if applicable):
RHL Roswell...
nfs-utils-0.3.1-11
am-utils-6.0.6-3
kernel-2.4.6-3.1

How reproducible:
Always

Steps to Reproduce:
Preliminary: Install RHL 7.2beta (Roswell), including am-utils; enable amd
with
"chkconfig --level 345 amd on"

METHOD 1 Steps to Reproduce:
1.  ls /net/<nfs-server-name>

METHOD 1 Actual Results:
At the console, I simply see nothing for ~60 seconds, and then an "input
output error" message.

In /var/log/messages, I see...

amd[909]: No fs type specified (key = "/defaults", map = ""root"")
amd[909]: get_nfs_version: failed to contact portmapper on host
"<nfs-server-name>": RPC: Timed out
amd[909]: get_nfs_version: failed to contact portmapper on host
"<nfs-server-name>": RPC: Timed out
amd[909]: Using NFS version 2, protocol udp on host <nfs-server-name>
amd[909]: start_ping: nfs_version: 2
amd[909]: get_nfs_version: failed to contact portmapper on host
"<nfs-server-name>": RPC: Timed out
...<repeated several times>...
amd[909]: Using NFS version 2, protocol udp on host <nfs-server-name>
kernel: nfs_stat_to_errno: bad nfs status return value: 11

METHOD 1 Expected Results:
Should list the directories exported by <nfs-server-name>.
In /var/log/messages, the first line ("No fs type....") and the "Using NFS
version 2..." lines are normal-- i.e. I also see these in the successful
cases.

METHOD 2 Steps To Reproduce
1. su
2. mkdir /mnt/<nfs-server-name>
3. mount -t nfs "<nfs-server-name>:/<dir>" /mnt/<nfs-server-name>

METHOD 2 Actual Results:
At the console I see nothing for about 60 seconds, and then "mount: RPC:
Timed out"
(No messages show up in /var/log/messages)

METHOD 2 Expected Results:
Should be able to "ls /net/<nfs-server-name>".


Additional info:
This is new to RHL 7.2beta (Roswell)
RHL 7.0 was fine.
RHL 7.1 does not exhibit this problem.  (I had other NFS troubles,
but the mounting process appeared to work smoothly.)

I am able ping & telnet back and forth with the server.
I get the same behavior regardless whether nfs & nfslock are explicitly
started up (via /etc/rc.d/...).

(If nothing else, that msg. from the kernel indicates a bug, right?)
Comment 1 Bob Matthews 2001-08-16 10:53:15 EDT
Is the portmapper running?
Comment 2 Bill Nottingham 2001-08-16 11:09:46 EDT
Did you set up a firewall?
Comment 3 Need Real Name 2001-08-16 19:16:04 EDT
portmap is running on both my machine and the nfs host.

I configured RHL7.2(beta) with Medium security, with Telnet, SSH, and maybe
something else enabled.  (If NFS was in that list, I selected that, too.)
Comment 4 Bob Matthews 2001-08-17 10:29:19 EDT
> (If NFS was in that list, I selected that, too.)

Well, NFS is not on the list. :)  But, it *is* blocked by default with a Medium
Security firewall.

Can you check the output of ipchains -L?  I'll bet that the nfs port is in the
REJECT list.

(Thanks to Bill N. for the catch.)
Comment 5 Need Real Name 2001-08-17 13:03:20 EDT
Looks like you are onto something.
ipchains -L says...

Chain input (policy ACCEPT):
target     prot opt     source                destination           ports
ACCEPT     udp  ------  140.102.16.111       anywhere              domain ->  
any
ACCEPT     udp  ------  140.102.100.111      anywhere              domain ->  
any
ACCEPT     tcp  -y----  anywhere             anywhere              any ->   ftp
ACCEPT     tcp  -y----  anywhere             anywhere              any ->   ssh
ACCEPT     tcp  -y----  anywhere             anywhere              any ->  
telnet
ACCEPT     all  ------  anywhere             anywhere              n/a
REJECT     tcp  -y----  anywhere             anywhere              any ->  
0:1023
REJECT     tcp  -y----  anywhere             anywhere              any ->   nfs
REJECT     udp  ------  anywhere             anywhere              any ->  
0:1023
REJECT     udp  ------  anywhere             anywhere              any ->   nfs
REJECT     tcp  -y----  anywhere             anywhere              any ->  
x11:6009
REJECT     tcp  -y----  anywhere             anywhere              any ->   xfs
Chain forward (policy ACCEPT):
Chain output (policy ACCEPT):
Comment 6 Bob Matthews 2001-08-17 16:30:30 EDT
Is this fixed if you delete the ipchain rule which blocks the nfs port?
Comment 7 Need Real Name 2001-08-29 12:46:35 EDT
Yup, nfs started working after I used ipchains -D...

Note You need to log in before you can comment on or make changes to this bug.