Bug 518876 - no valid [disk] devices were found
Summary: no valid [disk] devices were found
Keywords:
Status: CLOSED CANTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: rawhide
Hardware: ppc64
OS: Linux
low
medium
Target Milestone: ---
Assignee: Anaconda Maintenance Team
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-08-23 18:20 UTC by John Reiser
Modified: 2009-08-24 14:26 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-08-24 14:26:27 UTC


Attachments (Terms of Use)
/tmp/anaconda.log (3.46 KB, text/plain)
2009-08-23 18:20 UTC, John Reiser
no flags Details
/tmp/storage.log (4.64 KB, text/plain)
2009-08-23 18:21 UTC, John Reiser
no flags Details

Description John Reiser 2009-08-23 18:20:40 UTC
Created attachment 358369 [details]
/tmp/anaconda.log

Description of problem: The graphical installer cannot find the harddrive.


Version-Release number of selected component (if applicable):
anaconda=12.16

How reproducible: every time


Steps to Reproduce:
1. Download today's rawhide boot.iso for ppc; burn to CD-RW.
2. boot CD-RW on Apple iMac G5 (64-bit PowerPC)
3. Kernel will get an "Unrecoverable" oops (bug #518875). However, if you wait two or three minutes then things continue automagically!
4. Select Custom configuration of harddrives.
  
Actual results: "No devices found.  An error has occurred -- no valid devices were found on which to create new file systems.  Please check your hardware for the cause of the problem."


Expected results: Finds existing harddrive.


Additional info:

Comment 1 John Reiser 2009-08-23 18:21:19 UTC
Created attachment 358370 [details]
/tmp/storage.log

Comment 2 John Reiser 2009-08-23 19:45:45 UTC
"About this Mac" says that the disk is attached to a Serial-ATA bus, with properties:
  Removable Media:	No
  Detachable Drive:	No
  BSD Name:	disk0
  Protocol:	ata
  Unit Number:	0
  Socket Type:	Serial-ATA
  Mac OS 9 Drivers:	No
  Partition Map Type:	APM (Apple Partition Map)
  S.M.A.R.T. status:	Verified

The CD/DVD is on the ATA bus:
  Removable Media:	Yes
  Detachable Drive:	No
  BSD Name:	disk1
  Protocol:	ATAPI
  Unit Number:	0
  Socket Type:	Internal
  Low Power Polling:	Yes
  Power Off:	No
  Mac OS 9 Drivers:	No
  Partition Map Type:	Unknown
  S.M.A.R.T. status:	Not Supported

The lspci output is in an attachment to bug #518875.

Comment 3 Chris Lumens 2009-08-24 14:26:27 UTC
The kernel error is likely causing things to not show up in the udev database, which means anaconda's never going to see it.  Once that's fixed up, I bet everything will be fine in anaconda land.


Note You need to log in before you can comment on or make changes to this bug.