Bug 518907 (averatec-display) - Live CD starts on Averatech 3280 with too high screen resolution
Summary: Live CD starts on Averatech 3280 with too high screen resolution
Keywords:
Status: CLOSED WONTFIX
Alias: averatec-display
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-openchrome
Version: 13
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Xavier Bachelot
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: card_K8M800/K8N800
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-08-24 05:36 UTC by Peter Belew
Modified: 2018-04-11 16:31 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-06-28 14:16:08 UTC


Attachments (Terms of Use)
xorg.conf file which also works under Ubuntu. (1.72 KB, text/plain)
2009-08-24 05:36 UTC, Peter Belew
no flags Details
Xorg.0.log after adding xorg.conf (55.54 KB, text/plain)
2009-08-24 05:38 UTC, Peter Belew
no flags Details
lspci -v output (6.76 KB, text/plain)
2009-08-24 05:39 UTC, Peter Belew
no flags Details
lsmod output (2.75 KB, text/plain)
2009-08-24 05:40 UTC, Peter Belew
no flags Details
/proc/cpuinfo (511 bytes, text/plain)
2009-08-24 05:41 UTC, Peter Belew
no flags Details
/proc/meminfo (1.14 KB, text/plain)
2009-08-24 05:41 UTC, Peter Belew
no flags Details
Xorg.0.log after starting Fedora release 11.92 (Rawhide) live CD (49.32 KB, text/plain)
2009-11-06 00:29 UTC, Peter Belew
no flags Details


Links
System ID Priority Status Summary Last Updated
Launchpad 186103 None None None Never
Launchpad 296142 None None None Never

Description Peter Belew 2009-08-24 05:36:10 UTC
Created attachment 358393 [details]
xorg.conf file which also works under Ubuntu.

Description of problem:

 On booting the Fedora 11 live CD, the screen is initialized in too high a resolution (Maximum res. of the screen is 1024x768, and it starts up in 1600x1200, with the display cropped to the upper left part of the 1600x1200 virtual display.

Version-Release number of selected component (if applicable):

 Xorg components (via or openchrome driver etc.) in Fedora 11

How reproducible:

 On every boot.


Steps to Reproduce:
1. Insert CD
2. proceed with normal boot
3.
  
Actual results:

 Display is clipped to upper-left 1024x768 portion of virtual 1600x1200 screen. Using the System>Preference>Display dialog, the current display mode is seen to be 1600x1200. The upper panel of the Gnome screen is visible, and the resolution can be changed to 1024x768 with the Display dialog.

 I haven't tried this with the KDE version of Fedora, but with Kubuntu what happens is that the menus are on a bottom panel, off the visible screen, which makes recovery rather difficult, though possible.


Expected results:

 The screen resolution should be 1024x768 or lower, initially.


Additional info:

 I experienced this problem with Ubuntu and Kubuntu, previously (see linked Launchpad bug). Early in testing I ended up building an openchrome driver, but that driver seems to be in the latest releases, including this one. The remaining problem is that the 1600x1200 mode is set initially, which makes access to the full screen difficult and confusing for the average user.

Adding an appropriate xorg.conf file solves the problem, after Xorg is restarted. This is done by copying the 'good' xorg.conf file into /etc/X11, switching to a text console, and killing the Xorg process, which then restarts, reading and acting on the xorg.conf file while starting.

I'm attaching various other files, such as Xorg.0.log.

Comment 1 Peter Belew 2009-08-24 05:38:01 UTC
Created attachment 358394 [details]
Xorg.0.log after adding xorg.conf

This log shows the behavior after Xorg is restarted with the xorg.conf file in place.

Comment 2 Peter Belew 2009-08-24 05:39:27 UTC
Created attachment 358395 [details]
lspci -v output

Comment 3 Peter Belew 2009-08-24 05:40:02 UTC
Created attachment 358396 [details]
lsmod output

Comment 4 Peter Belew 2009-08-24 05:41:08 UTC
Created attachment 358397 [details]
/proc/cpuinfo

Comment 5 Peter Belew 2009-08-24 05:41:44 UTC
Created attachment 358398 [details]
/proc/meminfo

Comment 6 Peter Belew 2009-08-24 05:49:36 UTC
Note that there are 2 linked Ubuntu Launchpad bug reports.

There really needs to be a utility or boot command option for selecting an initial screen resolution in cases like this. Earlier versions of Ubuntu did provide this; I'm not sure about Fedora, since I haven't installed it since the first version. The average user shouldn't be expected to create an xorg.conf file.

Comment 7 Matěj Cepl 2009-11-05 18:36:54 UTC
Since this bugzilla report was filed, there have been several major updates in various components of the Xorg system, which may have resolved this issue. Users who have experienced this problem are encouraged to upgrade their system to the latest version of their packages. For packages from updates-testing repository you can use command

yum upgrade --enablerepo='*-updates-testing'

Alternatively, you can also try to test whether this bug is reproducible with the upcoming Fedora 12 distribution by downloading LiveMedia of F12 Beta available at http://alt.fedoraproject.org/pub/alt/nightly-composes/ . By using that you get all the latest packages without need to install anything on your computer. For more information on using LiveMedia take a look at https://fedoraproject.org/wiki/FedoraLiveCD .

Please, if you experience this problem on the up-to-date system, let us now in the comment for this bug, or whether the upgraded system works for you.

If you won't be able to reply in one month, I will have to close this bug as INSUFFICIENT_DATA. Thank you.

[This is a bulk message for all open Fedora Rawhide Xorg-related bugs. I'm adding myself to the CC list for each bug, so I'll see any comments you make after this and do my best to make sure every issue gets proper attention.]

Comment 8 Peter Belew 2009-11-06 00:29:51 UTC
Created attachment 367766 [details]
Xorg.0.log after starting Fedora release 11.92 (Rawhide) live CD

The same thing is happening with this beta release, still.

Version info:

Linux localhost.localdomain 2.6.31.1-56.fc12.i686 #1 SMP Tue Sep 29 16:32:02 EDT 2009 i686 athlon i386 GNU/Linux

Fedora release 11.92 (Rawhide)

Note that this still happens with the released version of Ubuntu 9.10 on this laptop.

Comment 9 Peter Belew 2009-11-19 19:46:20 UTC
Display initialization is the same with the released Fedora 12.0 live CD, but shortly after booting a message pops up saying the kernel crashed but also that the problem was not automatically reported.

Comment 10 Xavier Bachelot 2009-11-19 22:29:44 UTC
While running the F12 live CD, update to 0.2.904 from the updates-testing repo, then add the following line to the Device section of your xorg conf ;
Option "ModeSwitchMethod" "new"
It may or may not make a difference, but I'd like to see the xorg log in any case.

Comment 11 Xavier Bachelot 2010-03-20 13:30:03 UTC
Might be fixed with xorg-x11-drv-openchrome-0.2.904-2.fc11 which will hit
updates-testing shortly.

Comment 12 Bug Zapper 2010-04-28 09:55:57 UTC
This message is a reminder that Fedora 11 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 11.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '11'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 11's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 11 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping

Comment 13 Bug Zapper 2010-06-28 14:16:08 UTC
Fedora 11 changed to end-of-life (EOL) status on 2010-06-25. Fedora 11 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Comment 14 Peter Belew 2010-07-02 01:54:18 UTC
I just tried the Fedora 13 live CD, and the same initial screen resolution problem still happens. A 1600x1200 screen resolution is selected. Using the System>Preferences>Monitors dialog again allows selecting 1024x768 res.

I decided to try to install F13. On rebooting after the initial installation, another, very difficult, problem occurs. The full-screen configuration dialogs come up in 1600x1200 mode, and any Ok, Cancel, Back buttons are in the lower-left of the larger screen, thus invisible. I was able to proceed with the configuration after many tries, using the TAB key to select various invisible buttons.

After that, on logging out or rebooting, the screen with the GDM login was still at 1600x1200, with the dialog off-center at the lower right of the screen, but usable.

Finally, I installed a /etc/X11/xorg.conf file, the same as I list above on 2009-08-24. Once that was installed, the screen comes up in 1024x768 for login.

It might be possible to install the xorg.conf file from the live CD after the initial installation. That would avoid the problems with the fullscreen configuration dialogs.


Note You need to log in before you can comment on or make changes to this bug.