Bug 518923 - yum-3.2.23-14.fc12 + auto-update-debuginfo + priorities == traceback
Summary: yum-3.2.23-14.fc12 + auto-update-debuginfo + priorities == traceback
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: yum
Version: 12
Hardware: x86_64
OS: Linux
low
medium
Target Milestone: ---
Assignee: Seth Vidal
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:01a72b3f
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-08-24 07:53 UTC by Frank Murphy
Modified: 2014-01-21 23:11 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-12-09 12:55:04 UTC


Attachments (Terms of Use)
File: backtrace (2.45 KB, text/plain)
2009-08-24 07:53 UTC, Frank Murphy
no flags Details

Description Frank Murphy 2009-08-24 07:53:19 UTC
abrt detected crash.


How to reproduce
-----
1.
2.
3.


Commnet
-----
added priority=X to the various repos, added priority=1 to yum.conf

Additional information
======


Attached files
----
backtrace

cmdline
-----
/usr/bin/python /usr/bin/yum --skip-broken update 


component
-----
yum


executable
-----
/usr/bin/yum


kernel
-----
2.6.31-0.167.rc6.git6.fc12.x86_64


package
-----
yum-3.2.23-14.fc12


uuid
-----
01a72b3f

Comment 1 Frank Murphy 2009-08-24 07:53:22 UTC
Created attachment 358422 [details]
File: backtrace

Comment 2 James Antill 2009-08-24 14:35:27 UTC
 This appears to be:

post repo. setup calls auto-update-debuginfo which sets up a repo. which then calls priorities, which calls returnPackages() ... which dies.

So disabling either of those plugins should fix it, you might also want to look at the latest auto-update-debuginfo code from upstream. I'll try and find time to test.

Comment 3 Bug Zapper 2009-11-16 11:37:46 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 12 development cycle.
Changing version to '12'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping

Comment 4 Juan P. Daza P. 2009-12-09 02:35:47 UTC
Thank you for taking the time to report this bug. Updates to this package have been released since it was first reported. If you have time to update the package and re-test, please do so and report the results here. You can obtain the updated package by typing 'yum update yum-utils yum' or using the graphical updater, Software Update.

---

Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

Comment 5 Frank Murphy 2009-12-09 07:44:33 UTC
It's fine now, just forgot to say so, sorry.

Comment 6 Juan P. Daza P. 2009-12-09 12:55:04 UTC
Glad to hear that.

---

Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers


Note You need to log in before you can comment on or make changes to this bug.