Bug 518933 - Install of cups-pk-helper cause abort of running system-config-printer
Summary: Install of cups-pk-helper cause abort of running system-config-printer
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: system-config-printer
Version: 6.0
Hardware: x86_64
OS: Linux
low
low
Target Milestone: beta
: ---
Assignee: Tim Waugh
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-08-24 09:10 UTC by Tomas Pelka
Modified: 2009-08-25 08:39 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-08-24 14:15:35 UTC


Attachments (Terms of Use)

Description Tomas Pelka 2009-08-24 09:10:28 UTC
Description of problem:
Install of cups-pk-helper cause abort of running system-config-printer (s-c-p).

Version-Release number of selected component (if applicable):
cups-1.4-0.b2.18.fc11.x86_64
bluez-cups-4.37-1.fc11.x86_64
libgnomecups-0.2.3-5.fc11.x86_64
hal-cups-utils-0.6.19-2.fc11.x86_64
cups-pk-helper-0.0.4-1.fc11.x86_64
cups-libs-1.4-0.b2.18.fc11.x86_64


How reproducible:
100%

Steps to Reproduce:
1. Make sure that cups-pk-helper isn't installed. 
2. Run system-config-printer.
3. Try add new printer - should work.
4. Do not abort system-config-printer!
5. Install cups-pk-helper package.
6. Try add new printer, like in 3).
  
Actual results:
System-config-printer aborted, repeatedly started s-c-p works fine and properly.

Expected results:
S-c-p should inform user, that PolicyKit integration is present and s-c-p should be restarted.

Additional info:

Comment 2 RHEL Product and Program Management 2009-08-24 09:35:32 UTC
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.

Comment 3 Tim Waugh 2009-08-24 14:15:35 UTC
Works for me.

You haven't included the n-v-r of system-config-printer, or given details of any output to stdout/stderr so it is not possible to pursue this further.


Note You need to log in before you can comment on or make changes to this bug.