Bug 51899 - Database connection error
Summary: Database connection error
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Web Site
Classification: Red Hat
Component: Other   
(Show other bugs)
Version: current
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Web Development
QA Contact: Web Development
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-08-16 17:23 UTC by Jay Turner
Modified: 2015-01-07 23:50 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-09-04 23:52:40 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Jay Turner 2001-08-16 17:23:44 UTC
Description of Problem:
Getting this on webdev mailing list:

[WebDB] connection error:
+DBI->connect((DESCRIPTION=(ADDRESS=(PROTOCOL=TCP)(HOST=laa-laa.webqa.redhat.com+)(PORT=1521))(CONNECT_DATA=(SID=WEBQA))))
failed: ORA-12541: TNS:no listener
+(DBD ERROR: OCIServerAttach) at /var/www/cgi-bin/../lib/WebDB.pm line 212
  
[FakeDB] AUTOLOADING: FakeDB::prepare
[FakeDB] AUTOLOADING: FakeDB::execute
Unable to execute SQL fetch: ORA-12541: TNS:no listener (DBD ERROR:
+OCIServerAttach), stopped at /var/www/cgi-bin/rhce_app line 204.
[FakeDB] AUTOLOADING: FakeDB::DESTROY

from the cron operation:

/var/www/cgi-bin/rhce_app -dump && /var/www/bin/shove -q
/var/www/dhtml/rhce_app >/dev/null

Version-Release number of selected component (if applicable):


How Reproducible:


Steps to Reproduce:
1. 
2. 
3. 

Actual Results:


Expected Results:


Additional Information:

Comment 1 Tom Lancaster 2001-09-04 23:52:36 UTC
Looks like this dates back to webqa or webdev being down a while back.
FYI, loss of connection will probably result in FakeDB taking over - it's the
default NULL database driver.

Comment 2 Jay Turner 2001-09-18 14:04:06 UTC
Closing this out.


Note You need to log in before you can comment on or make changes to this bug.