Bug 519031 - RuntimeError: device is already mapped
Summary: RuntimeError: device is already mapped
Keywords:
Status: CLOSED DUPLICATE of bug 508796
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: rawhide
Hardware: x86_64
OS: Linux
low
medium
Target Milestone: ---
Assignee: Anaconda Maintenance Team
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: anaconda_trace_hash:cc73975620e8af499...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-08-24 16:40 UTC by Frank Murphy
Modified: 2009-08-25 19:37 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-08-25 19:37:38 UTC


Attachments (Terms of Use)
Attached traceback automatically from anaconda. (36.60 KB, text/plain)
2009-08-24 16:40 UTC, Frank Murphy
no flags Details

Description Frank Murphy 2009-08-24 16:40:08 UTC
The following was filed automatically by anaconda:
anaconda 12.16-1.fc12 exception report
Traceback (most recent call first):
  File "/usr/lib/anaconda/storage/devicetree.py", line 69, in getLUKSPassphrase
    raise RuntimeError("device is already mapped")
  File "/usr/lib/anaconda/storage/devicetree.py", line 1350, in handleUdevLUKSFormat
    self.__passphrase)
  File "/usr/lib/anaconda/storage/devicetree.py", line 1650, in handleUdevDeviceFormat
    self.handleUdevLUKSFormat(info, device)
  File "/usr/lib/anaconda/storage/devicetree.py", line 1254, in addUdevDevice
    self.handleUdevDeviceFormat(info, device)
  File "/usr/lib/anaconda/storage/devicetree.py", line 1868, in populate
    self.addUdevDevice(dev)
  File "/usr/lib/anaconda/storage/__init__.py", line 293, in reset
    self.devicetree.populate()
  File "/usr/lib/anaconda/storage/__init__.py", line 74, in storageInitialize
    storage.reset()
  File "/usr/lib/anaconda/dispatch.py", line 204, in moveStep
    rc = stepFunc(self.anaconda)
  File "/usr/lib/anaconda/dispatch.py", line 127, in gotoNext
    self.moveStep()
  File "/usr/lib/anaconda/gui.py", line 1201, in nextClicked
    self.anaconda.dispatch.gotoNext()
RuntimeError: device is already mapped

Comment 1 Frank Murphy 2009-08-24 16:40:25 UTC
Created attachment 358480 [details]
Attached traceback automatically from anaconda.

Comment 2 Frank Murphy 2009-08-24 16:45:52 UTC
home was pre-setup in /dev/sda3

install was to use free space before home
for default partitions.

had just inputted to use Irish keyboard, when exception happened.

Comment 3 Frank Murphy 2009-08-25 07:08:38 UTC
https://www.redhat.com/archives/fedora-list/2009-August/msg02201.html

Portions of this may be relevant?
As I also used gparted to setup the free-space.
Palimpsest Disk Utility, havng refused to allow permission.

Comment 4 Frank Murphy 2009-08-25 09:34:07 UTC
Solved (Hopefully)

When booting from the liveMedia.
As a reflex, I always entered luks p\w when asked.

If this is skipped, just press enter util boot continues.

Partitioning (gparted\Palimpsest) and then install work fine.
Maybe is may be the case for other similar events?

Comment 5 Andy Lindeberg 2009-08-25 13:53:07 UTC
That's not a solution, merely a workaround. Feel free to use it to avoid this problem, of course, but the underlying cause for the traceback should still be fixed.

Comment 6 Chris Lumens 2009-08-25 19:37:38 UTC

*** This bug has been marked as a duplicate of bug 508796 ***


Note You need to log in before you can comment on or make changes to this bug.