Bug 519056 - Rescheduled kickstarts are repeatedly appending onto 'append' in /etc/lilo.conf
Summary: Rescheduled kickstarts are repeatedly appending onto 'append' in /etc/lilo.conf
Keywords:
Status: CLOSED DEFERRED
Alias: None
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Provisioning
Version: 530
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Tomas Lestach
QA Contact: Red Hat Satellite QA List
URL:
Whiteboard:
Depends On:
Blocks: 462714
TreeView+ depends on / blocked
 
Reported: 2009-08-24 18:36 UTC by John Sefler
Modified: 2014-07-04 13:26 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-07-04 13:26:40 UTC


Attachments (Terms of Use)

Description John Sefler 2009-08-24 18:36:31 UTC
Description of problem:
While attempting to kickstart a RHEL4 box to RHEL5 through a Satellite Proxy (not sure if Proxy is important), my first kickstart failed and then when I attempted to reschedule the kickstart, another failure occurred.  Although I'm not sure why the first kickstart failed, I know that all of the follow-up attempts to reschedule the kickstart failed with:

<--- cut from stdout of rhn_check -vvv on the client --->
- reading URL: http://rlx-2-04.rhndev.redhat.com/cobbler/images/ks-rhel-i386-server-5-u3/vmlinuz
- ['/sbin/grubby', '--add-kernel', '/boot/vmlinuz', '--initrd', '/boot/initrd.img', '--args', '"ksdevice=link lang= console=ttyS0,38400n8 text ks=http://rlx-2-04.rhndev.redhat.com/cblr/svc/op/ks/system/rlx-0-04.rhndev.redhat.com_RegisteredThroughProxy:1 kssendmac acpi=noirq "', '--copy-default', '--lilo', '--make-default', '--title=kick1251151203']
- applying lilo changes
- ['/sbin/lilo']
Quoted string is too long near line 15 in file /etc/lilo.conf
command failed (1)
D: Sending back response (1, 'Kickstart failed. Koan error.', {'koan': 'command failed (1)'})
D: do_call packages.checkNeedUpdate ('rhnsd=1',)
D: local action status:  (0, 'rpm database not modified since last update (or package list recently updated)', {})


Notice the error "Quoted string is too long near line 15 in file /etc/lilo.conf".  Below is /etc/lilo.conf after 4 rescheduled kickstart attempts.  Notice how the append line grows longer with each attempted kickstart.


prompt
timeout=20
default=kick1251151203
boot=/dev/hda
map=/boot/map
install=/boot/boot.b
serial=0
linear

image=/boot/vmlinuz
        label=kick1251151203
        initrd=/boot/initrd.img
        read-only
        root=/dev/myvg/rootvol
        append="acpi=noirq console=tty0 console=ttyS0,38400n8 ksdevice=link lang= console=ttyS0,38400n8 text ks=http://rlx-2-04.rhndev.redhat.com/cblr/svc/op/ks/system/rlx-0-04.rhndev.redhat.com_RegisteredThroughProxy:1 kssendmac acpi=noirq  lang= console=ttyS0,38400n8 text ks=http://rlx-2-04.rhndev.redhat.com/cblr/svc/op/ks/system/rlx-0-04.rhndev.redhat.com_RegisteredThroughProxy:1 kssendmac acpi=noirq  lang= console=ttyS0,38400n8 text ks=http://rlx-2-04.rhndev.redhat.com/cblr/svc/op/ks/system/rlx-0-04.rhndev.redhat.com_RegisteredThroughProxy:1 kssendmac acpi=noirq  lang= console=ttyS0,38400n8 text ks=http://sun-x4200-01.rhts.bos.redhat.com/cblr/svc/op/ks/system/rlx-0-04.rhndev.redhat.com_RegisteredThroughProxy:1 kssendmac acpi=noirq "
image=/boot/vmlinuz
        label=kick1251150923
        initrd=/boot/initrd.img
        read-only
        root=/dev/myvg/rootvol
        append="acpi=noirq console=tty0 console=ttyS0,38400n8 ksdevice=link lang= console=ttyS0,38400n8 text ks=http://rlx-2-04.rhndev.redhat.com/cblr/svc/op/ks/system/rlx-0-04.rhndev.redhat.com_RegisteredThroughProxy:1 kssendmac acpi=noirq  lang= console=ttyS0,38400n8 text ks=http://rlx-2-04.rhndev.redhat.com/cblr/svc/op/ks/system/rlx-0-04.rhndev.redhat.com_RegisteredThroughProxy:1 kssendmac acpi=noirq  lang= console=ttyS0,38400n8 text ks=http://sun-x4200-01.rhts.bos.redhat.com/cblr/svc/op/ks/system/rlx-0-04.rhndev.redhat.com_RegisteredThroughProxy:1 kssendmac acpi=noirq "
image=/boot/vmlinuz
        label=kick1251148998
        initrd=/boot/initrd.img
        read-only
        root=/dev/myvg/rootvol
        append="acpi=noirq console=tty0 console=ttyS0,38400n8 ksdevice=link lang= console=ttyS0,38400n8 text ks=http://rlx-2-04.rhndev.redhat.com/cblr/svc/op/ks/system/rlx-0-04.rhndev.redhat.com_RegisteredThroughProxy:1 kssendmac acpi=noirq  lang= console=ttyS0,38400n8 text ks=http://sun-x4200-01.rhts.bos.redhat.com/cblr/svc/op/ks/system/rlx-0-04.rhndev.redhat.com_RegisteredThroughProxy:1 kssendmac acpi=noirq "
image=/boot/vmlinuz
        label=kick1251147763
        initrd=/boot/initrd.img
        read-only
        root=/dev/myvg/rootvol
        append="acpi=noirq console=tty0 console=ttyS0,38400n8 ksdevice=link lang= console=ttyS0,38400n8 text ks=http://sun-x4200-01.rhts.bos.redhat.com/cblr/svc/op/ks/system/rlx-0-04.rhndev.redhat.com_RegisteredThroughProxy:1 kssendmac acpi=noirq "
image=/boot/vmlinuz-2.6.9-78.EL
        label=linux
        initrd=/boot/initrd-2.6.9-78.EL.img
        read-only
        root=/dev/myvg/rootvol
        append="acpi=noirq console=tty0 console=ttyS0,38400n8"


Version-Release number of selected component (if applicable):
staged (Satellite-5.3.0-RHEL5-re20090724.0) with updates from Aug 20, 2009

How reproducible:


Steps to Reproduce:
1. register a RHEL 4 client to satellite (not sure if registering through a proxy is important for the recreate)
2. create a kickstart profile for RHEL 5
3. schedule the kickstart (and do something - not sure what - to cause the kick start to fail).  Then do it again causing it to fail.  The purpose is to cause repeated kickstart entries in /etc/lilo.conf
4. eventually on the second or third failure the reason should be because line 15 of /etc/lilo.conf (the append line) is too long.
  
Actual results:
Quoted string is too long near line 15 in file /etc/lilo.conf
command failed (1)
D: Sending back response (1, 'Kickstart failed. Koan error.', {'koan': 'command failed (1)'})

Expected results:
The append entries in /etc/lilo.conf should not grow as kickstarts are added.

Additional info:

Comment 1 John Sefler 2009-08-24 19:02:42 UTC
Upon further review, I think the first failed kickstart can be forced by registering the client through a proxy and scheduling the kickstart through the proxy as well as setting a long (50chars+) profile name for the client.  I think this will cause the append value on line 15 to go beyond it length limit.

However, remember that the real bug being reported here is that the rescheduled kickstarts cause the line to grow and grow.


Note You need to log in before you can comment on or make changes to this bug.