Bug 51918 - Need to document dependence of sendmail on hosts.allow
Summary: Need to document dependence of sendmail on hosts.allow
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: sendmail   
(Show other bugs)
Version: 7.1
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Florian La Roche
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-08-16 21:08 UTC by Need Real Name
Modified: 2007-04-18 16:35 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-08-19 14:30:16 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Need Real Name 2001-08-16 21:08:09 UTC
Description of Problem:

Under RH7.1 sendmail is checking /etc/hosts.allow to determine whether or
not to accept incoming connections, even though it "shouldn't" since this
isn't an xinetd-based service. Unfortunately the documentation doesn't seem
to mention this at all.

This can be fixed just by adding some notes to the docs that indicate that
a line should be added to hosts.allow for the service named "sendmail",
otherwise following the usual syntax.

If users set up a hosts.allow file without this line it can lead to an
overall failure of the sendmail system and dropped messages.

Version-Release number of selected component (if applicable):
sendmail-8.11.2-14 under RH7.1



How Reproducible: vide supra


Expected Results:


Additional Information:
	
Thanks!

Comment 1 Michael Schwendt 2001-08-19 14:30:12 UTC
/etc/hosts.allow and /etc/hosts.deny have nothing to do with xinetd. They are
used by the tcp_wrappers library (libwrap).

By default, RH7.1 does not deny access via hosts.deny. But you are right, this
should have been documented in the RELEASE-NOTES and not just in the sendmail
rpm changelog.


Note You need to log in before you can comment on or make changes to this bug.