Bug 519209 - Implement pptp vpn export
Summary: Implement pptp vpn export
Keywords:
Status: CLOSED UPSTREAM
Alias: None
Product: Fedora
Classification: Fedora
Component: NetworkManager-pptp
Version: 14
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Dan Williams
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 511070 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-08-25 16:31 UTC by Jonathan Kamens
Modified: 2012-05-08 13:41 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-05-08 13:28:19 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
GNOME Bugzilla 573987 None None None Never

Description Jonathan Kamens 2009-08-25 16:31:25 UTC
I have NetworkManager, NetworkManager-pptp and NetworkManager-gnome from rawhide.

When I start the NetworkManager service for the same time, it correctly imports a VPN that I've previously configured with pptpconfig, and displays it in nm-connection-editor.

However, when I try to edit the configuration of the VPN, check "Available to all users", and then click "Apply", I get this:

Saving connection failed: (0) Can't write connection type 'vpn'

I have no idea what this means.

Comment 1 Dan Williams 2009-11-07 04:13:02 UTC
export is not implemented for PPTP at this time.

Comment 2 Dan Williams 2009-11-07 04:14:00 UTC
speaking of which, neither is import... did you manually import your pptp vpn connection, or...?

Comment 3 Dan Williams 2009-11-07 04:14:57 UTC
*** Bug 511070 has been marked as a duplicate of this bug. ***

Comment 4 Jonathan Kamens 2009-11-12 21:56:59 UTC
I didn't import anything.  My existing PPTP VPN connection just showed up when I first ran NetworkManager.

Comment 5 Bug Zapper 2009-11-16 11:40:48 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 12 development cycle.
Changing version to '12'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping

Comment 6 Samuli Lager 2010-09-21 08:47:45 UTC
The export button should be greyed if the export is not possible to do.

Comment 7 Bug Zapper 2010-11-04 10:22:53 UTC
This message is a reminder that Fedora 12 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 12.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '12'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 12's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 12 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping

Comment 8 Michael Monreal 2010-11-04 16:08:28 UTC
Still not working on F14 (someone please bump up version field)

Comment 9 Nicola Soranzo 2010-11-04 16:17:37 UTC
(In reply to comment #8)
> Still not working on F14 (someone please bump up version field)

Bumped. Thanks for the info.

Comment 10 Dan Winship 2012-05-08 13:28:19 UTC
tracked upstream as https://bugzilla.gnome.org/show_bug.cgi?id=573987


Note You need to log in before you can comment on or make changes to this bug.