Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 519235 - AttributeError: 'DeviceFormat' object has no attribute 'partedDisk' when doing kickstart
Summary: AttributeError: 'DeviceFormat' object has no attribute 'partedDisk' when doin...
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: 12
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: David Lehman
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-08-25 19:05 UTC by Jesse Keating
Modified: 2013-01-10 03:30 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-02-23 19:27:36 UTC
Type: ---


Attachments (Terms of Use)

Description Jesse Keating 2009-08-25 19:05:21 UTC
I'm having to transcribe this because I didn't get a file a bug box:

File: "/usr/bin/anaconda", line 947, in <module>
  kickstart.fullCommandPass(anaconda, opts.ksfile, earlyKS)
File "/usr/lib/anaconda/kickstart.py", line 1202, in fullCOmmandPass
  storage.storageInitialize(anaconda)
File "/usr/lib/anaconda/storage/__init__.py", line 92, in storageInitialize
  storage.reset()
File "/usr/lib/anaconda/storage/__init__.py", line 293, in reset
  self.devicetree.populate()
File "/user/lib/anaconda/storage/devicetree.py", line 1868, in populate
  self.addUdevDevice(dev)
File "/usr/lib/anaconda/storage/devicetree.py", line 1201, in addUdevDevice
  device - self.addUdevDMDevice(info)
File "/usr/lib/anaconda/storage/devicetree.py", line 1009, in addUdevDMDevice
  exists=True, parents=[disk])
File "/usr/lib/anconda/storage/devices.py", line 848, in __init__
  self._partedPartition = self.disk.format.partedDisk.getPartitionByPath(self.path)
AttributeError: 'DeviceFormat' object has no attribute 'partedDisk'

Comment 1 Chris Lumens 2009-08-27 17:42:56 UTC
If you can reproduce this problem, can you please attach the complete traceback?  Of course you can always scp the dump file from tty2.

Comment 2 David Lehman 2009-08-28 16:03:49 UTC
Fixed in anaconda-12.18-1.

Comment 3 Bug Zapper 2009-11-16 11:41:31 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 12 development cycle.
Changing version to '12'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping


Note You need to log in before you can comment on or make changes to this bug.