Bug 519288 - crash at anaconda start using askmethod
Summary: crash at anaconda start using askmethod
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: rawhide
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Radek Vykydal
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-08-25 22:43 UTC by Todd
Modified: 2009-10-23 09:44 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-10-23 09:44:24 UTC


Attachments (Terms of Use)

Description Todd 2009-08-25 22:43:11 UTC
boot from i38s boot.iso dated 8-22-2009 and appended askmethod to the kernel.

choses url for methed, then system crash after  network setup.

loader recieved SIGSEGV! Backtrace:
/sbin/loader[0x804e161]
[0xd88400]
/lib/libc.so.6(strrchr+0xa3)[0x9ea453]
/sbin/loader[0x805fbd3]
/sbin/loader[0x804f80b]
/lib/libc.so.6(__libc_start_main=0xe6)[0x987b56]
/sbin/loader[0x804bee1]
install exited abnormally [1/1]

Comment 1 Chris Lumens 2009-08-26 14:45:13 UTC
eu-addr2line sez...

0x805fbd3 - urlinstall.c:260
0x804f80b - loader.c:1582

Comment 2 Chris Lumens 2009-08-26 14:47:57 UTC
Sorry, that should be urlinstall.c:118, which is the only place strrchr is used in that file anyway.

Comment 3 Radek Vykydal 2009-08-26 17:46:13 UTC
I think that the problem is that we are treating loaderData->stage2Data coming from iso.boot boot parameters (thus of "hd type" hdInstallData type) as of "url type" urlInstallData. It happens because askmethod + stage2= is broken (bugs #518194 (?), #516973). I sent a patch to fix it for review and the patch should handle also this case (loader goes right to hdd method screen, and after going back and to url method there is the SIGSEGV).
The patch is:
https://www.redhat.com/archives/anaconda-devel-list/2009-August/msg00335.html
If you agree with my analysis, I'm ok with reassigning to me.

Comment 4 Chris Lumens 2009-08-26 18:49:11 UTC
*** Bug 519206 has been marked as a duplicate of this bug. ***

Comment 5 James G. Brown III 2009-08-26 21:29:15 UTC
I can readily test this 9-5 EST... Let me know if I can help. 

- James

Comment 8 Todd 2009-09-04 00:27:53 UTC
I got the latest boot.iso image dated 9-2-2009 Crash still happens in the some place, but the backtrace is a bit different

loader recieved SIGSEGV! Backtrace:
/sbin/loader[0x804e161]
[0x692400]
/lib/libc.so.6(strrchr+0x3a)[0x9bf9a3]
/sbin/loader[0x805fd08]
/sbin/loader[0x804f7eb]
/lib/libc.so.6(__libc_start_main+0xe6)[0x95cb66]
/sbin/loader[0x804bee1]

Comment 9 Radek Vykydal 2009-09-10 10:01:36 UTC
Should be fixed in version 12.24 of anaconda. Thanks for the report.

Comment 10 James G. Brown III 2009-09-16 14:31:19 UTC
Radek, I am having the same issue this still simply does not work maneuvering as described below. AFAICT I should be using version 12.24-1 of anaconda.

**It should be noted that escaping out of the Install/upgrade screen and specifying 'linux askmethod' at boot: does work and there is not backtrace.**

How to reproduce;

http://mirror.uoregon.edu/fedora/linux/development/x86_64/os/images/

boot.iso	15-Sep-2009 05:36 	167M

After booting from the boot.iso on a usb key and selecting Install/Upgrade, then selecting the language and keyboard, I am presented with the "Select Partition" screen that asks for the "Directory holdings image:" and lists the local sd* devices and prompting to "press F2 to configure additional devices".

After pressing F2 I am presented with the "Driver Disk Source" screen at which point I press Back to finally get to the "Installation Method" screen where I can select URL to install from. After selecting URL it takes you to the "Configure TCP/IP" screen which asks about static or dhcp (either of which produce the same backtrace). 

At this point while configuring NM we receive the following backtrace;

loader recieved SIGSEGV! Backtrace:
/sbin/loader[0x40782e]
/lib/libc.so.6(+0x335f0)[0x7fbd098ee5f0]
/lib/libc.so.6(strrchr+0x1a)[0x7fbd0993dc8a]
/sbin/loader[0x418098]
/sbin/loader[0x408e11]
/lib/libc.so.6(__libc_start_main+0xfd)[0x7fbd098d9b4d]
/sbin/loader[0x4058f9] 
install exited abnormally [1/1]
you may safely reboot your system

As an aside, maybe replacing "you may safely reboot your system" with "Hey, we've had a fatal error here please report to bugzilla.redhat.com" might be more appropriate. 

It appears as if everything works in vty4 and we get an ip get a hostname, but directly after this we see

nm-dispathcer.action: nm_dispatcher_action: Invalid connection: '(null)' /
'connection setting not found' invalid:1  
NetworkManager:    ifcfg-rh: updating /etc/sysconfig/network-scripts/ifcfg-eth0

Again, This boot.iso does work when escaping out of the Install/Update splash screen where you are presented with the 'boot:' prompt and you initiate installation using 'linux askmethod'

Comment 11 Radek Vykydal 2009-09-17 08:31:47 UTC
James, you should file new bug for your issue, this one is regarding askmethod which, as you said, is working for you. I'll look into your issue.

Comment 12 James G. Brown III 2009-09-17 12:10:32 UTC
Radek, Much appreciated. I have reopened my original BZ 519206 and updated it with my last as well. Thanks!

- James

Comment 13 Radek Vykydal 2009-10-23 09:44:24 UTC
Closing based on the last paragraph of comment #10.


Note You need to log in before you can comment on or make changes to this bug.