Bug 519330 - MCP55 USB [10de:036c] (rev a1) as ohci -> ehci handoff broken
Summary: MCP55 USB [10de:036c] (rev a1) as ohci -> ehci handoff broken
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 11
Hardware: All
OS: Linux
low
urgent
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-08-26 07:52 UTC by Jón Fairbairn
Modified: 2009-08-28 08:28 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-08-28 08:28:45 UTC


Attachments (Terms of Use)
Output of lsusb -v (7.67 KB, text/plain)
2009-08-26 07:52 UTC, Jón Fairbairn
no flags Details
output of lspci -nn | egrep -i usb (184 bytes, text/plain)
2009-08-26 07:54 UTC, Jón Fairbairn
no flags Details
output of lspci -s 00:02 -vnnx under fedora 9 (1.20 KB, application/octet-stream)
2009-08-26 19:17 UTC, Jón Fairbairn
no flags Details
output of lsusb -v with ohci_hcd unloaded (4.62 KB, application/octet-stream)
2009-08-26 19:19 UTC, Jón Fairbairn
no flags Details

Description Jón Fairbairn 2009-08-26 07:52:58 UTC
Created attachment 358678 [details]
Output of lsusb -v

Description of problem:
I have an MSI MS-7250 Version: 2.0 motherboard, with two usb 2.0 hubs on board,
but the kernel gives the one that has the on-board sockets to ohci_hcd, resulting in very slow usb access.


Version-Release number of selected component (if applicable):
kernel-2.6.29.6-217.2.8.fc11.x86_64

How reproducible:
Every boot I've tried recently

Steps to Reproduce:
1.boot machine
2.attach usb device
3.use lsusb etc to show that it's attached to an ohci_hcd controlled port
  
Actual results:
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub


Expected results:

Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 2.0 root hub

Additional info:

I've only just needed to attach usb 2.0 devices to this machine after upgrading to f11.  In the past it was something I didn't do often, but it's essential now.
On Fedora 9, I did notice that sometimes the built-in usb ports were ohci, but removing the ohci module seemed to get round it, and as it wasn't something I often did, I didn't investigate. Now that I want to use them frequently, I find that usb is compiled in, so I can't get round it this way.

Comment 1 Jón Fairbairn 2009-08-26 07:54:58 UTC
Created attachment 358679 [details]
output of lspci -nn | egrep -i usb

The two hubs are reported to have different ids, but I'm sure that they are both 2.0 capable

Comment 2 Jón Fairbairn 2009-08-26 08:02:15 UTC
MSI 7250 v2.x is aka K9N Ultra.  The user manual definitely says that the ports on the back are USB 2.0

Presumably there's an incorrect mapping from pci ids to driver in the kernel, which needs to be mended, but in the meantime is there anything I can do to force the kernel's hand?

Comment 3 Jón Fairbairn 2009-08-26 19:17:35 UTC
Created attachment 358757 [details]
output of lspci -s 00:02 -vnnx under fedora 9

Just now I rebooted using a fedora 9 livecd to see what the problem was like with modules.  lsusb still reported both a 1.1 and 2.0 hub. After removing the ohci_hcd module lsusb reported only one, 2.0 hub, but the back panel sockets worked using that driver.  My guess now would be that they're the same device in some sense, and ohci_hcd masks access to it when it's loaded.

Comment 4 Jón Fairbairn 2009-08-26 19:19:35 UTC
Created attachment 358758 [details]
output of lsusb -v with ohci_hcd unloaded

Comment 5 Chuck Ebbert 2009-08-27 21:04:52 UTC
The ohci driver is supposed to hand over the port to ehci when a usb 2.0 device is connected.

Comment 6 Jón Fairbairn 2009-08-28 08:28:45 UTC
It looks like it does.  It seems that the device in question is actually a USB 1.1 device and that the speed problems are caused elsewhere; the confusion comes from using the same device on a different machine (same kernel, but i686 rather than x86_64 and an Intel USB controller) and getting much better speeds. I shall have to do further tests.

Hearty apologies for the misreporting.


Note You need to log in before you can comment on or make changes to this bug.