Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be unavailable on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 519337 - Anaconda uses device name for raid arrays in /etc/fstab instead of UUID
Summary: Anaconda uses device name for raid arrays in /etc/fstab instead of UUID
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: rawhide
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Hans de Goede
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-08-26 08:34 UTC by Bruno Wolff III
Modified: 2009-09-04 08:01 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-09-04 08:01:40 UTC
Type: ---


Attachments (Terms of Use)

Description Bruno Wolff III 2009-08-26 08:34:46 UTC
Description of problem:
After installing rawhide I had problems booting because /etc/fstab used a device name of /dev/md0 for /boot and dracut wasn't starting the array on /dev/md0.

Version-Release number of selected component (if applicable):
I think it was 12.16, but might have been 12.15.

How reproducible:
It happened on two fresh installs.

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
/etc/fstab:
#
# /etc/fstab
# Created by anaconda on Mon Aug 17 02:42:39 2009
#
# Accessible filesystems, by reference, are maintained under '/dev/disk'
# See man pages fstab(5), findfs(8), mount(8) and/or vol_id(8) for more info
#
/dev/md0                /boot                   ext4    defaults        1 2
/dev/mapper/luks-f92cb175-069f-46a4-98ca-a6beb32719bb /                       ext4    defaults        1 1
/dev/mapper/luks-b80e010b-375c-4567-9e8e-d92dc7effc17 /spare                  ext4    defaults        1 2
tmpfs                   /dev/shm                tmpfs   defaults        0 0
devpts                  /dev/pts                devpts  gid=5,mode=620  0 0
sysfs                   /sys                    sysfs   defaults        0 0
proc                    /proc                   proc    defaults        0 0

Comment 1 Hans de Goede 2009-09-04 08:01:40 UTC
This is fixed by this commit:
http://git.fedorahosted.org/git/?p=anaconda.git;a=commitdiff;h=0f3fc91e0a1ea8173e15de622d58f08c824140c7

Which will be in anaconda-12.21-1


Note You need to log in before you can comment on or make changes to this bug.