Bug 519659 - Password edit box cannot regain input focus
Summary: Password edit box cannot regain input focus
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: gdm
Version: 12
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: jmccann
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 522031 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-08-27 10:25 UTC by Michael Schwendt
Modified: 2015-01-14 23:23 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-12-02 12:08:45 UTC
Type: ---


Attachments (Terms of Use)

Description Michael Schwendt 2009-08-27 10:25:12 UTC
F12 Alpha

1.) For unknown reasons, the keyboard layout chosen in Anaconda was not made the default in GDM. Only after I had logged in, I noticed it and used "System > Preferences > Keyboard" to add and enable the layout for Germany - eliminate dead keys.

2.) After logging out, GDM still defaulted to keyboard layout "USA". I opened the "Other..." dialog to choose "Germany - eliminate dead keys" and could not enter my password. The password prompt was opened but disabled. No cursor. I had to click "Cancel" and retry.

Reproducibility: Always

Steps to reproduce:
1. On GDM login screen, choose/click a user, don't enter a password, wait for the session settings to appear at the bottom
2. In the keyboard layout combobox, choose "Other..." and choose a new keyboard layout
3. Password prompt gets disabled. One cannot type in the password and must "Cancel".

Comment 1 Sergey Rudchenko 2009-09-15 19:35:05 UTC
    Thank you for taking the time to report this bug. In order to provide suitable tracking of bugs, the bug writing guidelines (https://bugzilla.redhat.com/page.cgi?id=bug-writing.html) ask that reporters file one bug per issue. It appears that this bug contains multiple issues. If you have time and can still reproduce the bug (or bugs), please submit them as separate bugs for each of your separate issues. One bug can remain in this report; simply edit the summary to reflect this. You can note the new bug numbers in a comment for this bug. 

    Thank you.

---

Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

Comment 2 Sergey Rudchenko 2009-09-15 19:36:30 UTC
*** Bug 522031 has been marked as a duplicate of this bug. ***

Comment 3 Bug Zapper 2009-11-16 11:45:08 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 12 development cycle.
Changing version to '12'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping

Comment 4 Matthias Clasen 2009-12-02 01:51:25 UTC
I have not been able to reproduce the second issue in current F12. Are you still seeing this problem (password entry disabled after keyboard change) ?

Comment 5 Michael Schwendt 2009-12-02 12:08:45 UTC
No, with F12 final there are no such problems.


Note You need to log in before you can comment on or make changes to this bug.