Bug 51967 - rpm-4.0.3-0.?? broke backward compat (librpmxx.so.0)
rpm-4.0.3-0.?? broke backward compat (librpmxx.so.0)
Status: CLOSED WONTFIX
Product: Red Hat Raw Hide
Classification: Retired
Component: rpm (Show other bugs)
1.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jeff Johnson
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-08-17 13:13 EDT by Miguel Freitas
Modified: 2007-04-18 12:36 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-08-17 13:13:35 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Miguel Freitas 2001-08-17 13:13:32 EDT
Description of problem:
RPM-4.0.3-0.88 (and earlier?) doesn't provide the files:

librpm.so.0
librpmbuild.so.0
librpmio.so.0

Breaking backward compatibility with already compiled programs.
I installed kde-2.2 (that ships an rawhide rpm lib) and had
to remove rpmfind, gnorpm among others. red-carpet doesn't work anymore.


Version-Release number of selected component (if applicable):
4.0.3-0.88

How reproducible:
Always

Steps to Reproduce:
1.install kde-2.2 over a rh-7.1

Them already compiled rpm progs will not work anymore.


 I think it's fine to put version on the library names
(eg. librpm-4.0.3.so), but please maintain some compatibility
with compiled apps were possible...
librpm.so.0 were provided since version 3 up to 4.0.3
found at ftp.rpm.org.
Comment 1 Jeff Johnson 2001-08-17 13:23:14 EDT
Yup.

This (and 2 other changes) was announced on rpm-list, grab the text from the
archives
at http://listman.redhat.com. Basically, rpm shared libraries have never been
backward compatible. In rpm-4.0.3, the rpmdb API moved to librpmdb.so.0,
and, since librpm.so.0 is not linked against other libraries, breaks
compatibility
anyways. There are deeper problems than library linkage as well ...

Note You need to log in before you can comment on or make changes to this bug.