Bug 51968 - roswell upgrade lost krb5 ld.so.conf entry
Summary: roswell upgrade lost krb5 ld.so.conf entry
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Public Beta
Classification: Retired
Component: krb5   
(Show other bugs)
Version: roswell
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Nalin Dahyabhai
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-08-17 17:24 UTC by Stephen Tweedie
Modified: 2007-04-18 16:36 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-08-21 20:21:19 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Stephen Tweedie 2001-08-17 17:24:05 UTC
Description of Problem:

After an upgrade from 7.1 to Roswell1, kerberos breaks --- the
"/usr/kerberos/lib" entry was missing from /etc/ld.so.conf, breaking all
binaries which link against krb5.

Adding the missing ld.so.conf entry and rerunning ldconfig fixed things.

This may be an side-effect of another bug --- anaconda did not account for
the amount of space required in /var/lib/rpm and so a previous upgrade
attempt had already aborted with ENOSPACE, and it is conceivable that the
krb5 libs had been upgraded by that point but that ld.so.conf had not been
updated.

Comment 1 Glen Foster 2001-08-17 18:56:43 UTC
If you can reproduce this behavior, please say so in this bug and it'll be
marked SHOULD-FIX.

Comment 2 Brian Brock 2001-08-21 20:21:15 UTC
I can't reproduce this, which packages do you think were installed on the 7.1
system?

Comment 3 Stephen Tweedie 2001-08-22 10:46:20 UTC
Not reproduced here, either.  I'm pretty sure it's a side-effect of the anaconda
failure.  I'll log that separately against anaconda.



Note You need to log in before you can comment on or make changes to this bug.