This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 519754 - HP nx6110 laptop lid switch does not work
HP nx6110 laptop lid switch does not work
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
11
i686 Linux
low Severity low
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-08-27 13:11 EDT by Armands Liepins
Modified: 2010-06-28 10:20 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-06-28 10:20:16 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
/var/log/dmesg (30.50 KB, text/plain)
2009-08-27 13:11 EDT, Armands Liepins
no flags Details

  None (edit)
Description Armands Liepins 2009-08-27 13:11:43 EDT
Created attachment 358923 [details]
/var/log/dmesg

Description of problem:
It half-worked with f10, now it does not work completely. Since as I understand this is related to acpi too, I can report that radio kill switch led is always on, regardless of radio state and it worked with f10.

Version-Release number of selected component (if applicable):
kernel-2.6.29.6-217.2.16.fc11.i586
acpid-1.0.8-4.fc11.i586

How reproducible:
always

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Armands Liepins 2009-09-06 07:40:01 EDT
I can turn led on and off through /sys/class/leds/b43-phy0\:\:radio/brightness
there is /proc/acpi/button/lid/C1E9/state, but it allways says:
state:      closed
Comment 2 Armands Liepins 2009-09-06 08:07:52 EDT
hmm, strange, if acpid is stopped, then pressing lid switch does nothing, but pressing radio kill switch generates such events at /proc/acpi/event:
video C055 00000080 00000000
button/lid C1E9 00000080 000003aa

on f10 lid switch started to work if radio kill button has been pressed before that.
Comment 3 Bug Zapper 2010-04-28 06:01:21 EDT
This message is a reminder that Fedora 11 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 11.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '11'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 11's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 11 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 4 Bug Zapper 2010-06-28 10:20:16 EDT
Fedora 11 changed to end-of-life (EOL) status on 2010-06-25. Fedora 11 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.