Bug 519987 - libsepol.scope_copy_callback: polkit_auth: Duplicate declaration in module: type/attribute polkit_var_lib_t
Summary: libsepol.scope_copy_callback: polkit_auth: Duplicate declaration in module: t...
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: selinux-policy-targeted
Version: rawhide
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Daniel Walsh
QA Contact: Ben Levenson
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-08-27 21:23 UTC by Mads Kiilerich
Modified: 2009-08-28 12:57 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-08-28 12:57:03 UTC


Attachments (Terms of Use)

Description Mads Kiilerich 2009-08-27 21:23:39 UTC
Description of problem:

# rpm -e selinux-policy-targeted
# yum install selinux-policy-targeted
...
Running Transaction
  Installing     : selinux-policy-targeted-3.6.28-8.fc12.noarch                                                                                                         1/1 
libsepol.scope_copy_callback: polkit_auth: Duplicate declaration in module: type/attribute polkit_var_lib_t (No such file or directory).
libsemanage.semanage_link_sandbox: Link packages failed (No such file or directory).
semodule:  Failed!

Installed:
  selinux-policy-targeted.noarch 0:3.6.28-8.fc12                                                                                                                            


Version-Release number of selected component (if applicable):

selinux-policy-targeted-3.6.28-8.fc12.noarch
How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 Daniel Walsh 2009-08-27 21:44:14 UTC
What does 
 semodule -n -s targeted -r moilscanner -r mailscanner -r gamin -r audio_entropy -r iscsid -r polkit 

Return for errors?

Comment 2 Mads Kiilerich 2009-08-27 23:35:35 UTC
[root@localhost ~]# semodule -n -s targeted -r moilscanner -r mailscanner -r gamin -r audio_entropy -r iscsid -r polkit
libsemanage.semanage_direct_remove: Module moilscanner was not found.
libsemanage.semanage_direct_remove: Module mailscanner was not found.
libsemanage.semanage_direct_remove: Module gamin was not found.
libsemanage.semanage_direct_remove: Module audio_entropy was not found.
libsemanage.semanage_direct_remove: Module iscsid was not found.
libsemanage.semanage_direct_remove: Module polkit was not found.
semodule:  Failed!

(23:45:51) dgrift: can you do a semodule -l | grep pol
(23:46:13) kiilerix1: polkit_auth	1.0.0
(23:46:29) dgrift: thats wrong
(23:46:48) dgrift: remove that module and reinstall policy
(23:46:59) dgrift: semodule -r polkit_auth
(23:47:40) dgrift: yum update --replace-files --replace-pkgs selinux-policy
(23:47:45) dgrift: yum update --replace-files --replace-pkgs selinux-policy*
(23:48:20) dgrift: looks like an error fedora made
(23:48:57) dgrift: but you might want to restorecon after that
(23:49:01) dgrift: relabel
(23:49:23) dgrift: after you did that see if its gone
(23:49:36) dgrift: you should have a policykit 1.0.1 instead

The system was updated from F11 to rawhide. dgrift suggested how I could fix the issue with selinux brain surgery or by installing more or less the whole system, but I assume that the rpm update should do the right thing, so I will rather wait and see if there will come an update which I then can test.

I currently have SELINUX=disabled (for no good reason), if that has any influence.

I notice that I have /etc/selinux/targeted/policy/policy.24 but the rpm has %ghost .23 - I don't know if that is related or not.

Comment 3 Daniel Walsh 2009-08-28 12:57:03 UTC
Ok I will fix it if you turn SELinux back on.  :^)

Fixed in selinux-policy-3.6.28-9.fc12.noarch


Note You need to log in before you can comment on or make changes to this bug.