Bug 520026 - nm applet can't disable only 1 wireless card when multiple are present.
Summary: nm applet can't disable only 1 wireless card when multiple are present.
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: NetworkManager
Version: 11
Hardware: All
OS: Linux
low
high
Target Milestone: ---
Assignee: Dan Williams
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-08-28 04:12 UTC by Christ Schlacta
Modified: 2009-11-07 04:02 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-11-07 04:02:09 UTC
Type: ---


Attachments (Terms of Use)

Description Christ Schlacta 2009-08-28 04:12:58 UTC
Description of problem:
network manager applet has no option to disable a specific interface while leaving another functional (at least for wireless)

Version-Release number of selected component (if applicable):


How reproducible:
very

Steps to Reproduce:
1. install 2 wireless cards that are supported
2. try to disable one using the network manager applet
3. reach same conclusion that I did.  there is no way to do it currently.
  
Actual results:
impossible to do

Expected results:
select "disable" option next to specific card and have it disconnect and take down the interface and not try to reconnect

Additional info:
I know two wireless cards in one system is rare, but that's what I have.

Comment 1 Dan Williams 2009-11-07 04:02:09 UTC
In Fedora 12, you can disconnect either or both of the wifi cards and it won't auto-activate.  Unfortunately until the 2.6.32 kernel it's not possible to rfkill just one of the cards, because it's not possible to conclusively match up each card to its rfkill switch if there is one.  We also can't tell which card is internal and which is external, or whatever.

So I'd give Fedora 12 a try and use the "disconnect" option which should pretty much be what you're looking for here.


Note You need to log in before you can comment on or make changes to this bug.