Bug 52006 - NFS mounts from a NIS client host fail on boot
NFS mounts from a NIS client host fail on boot
Status: CLOSED DUPLICATE of bug 133333
Product: Fedora
Classification: Fedora
Component: initscripts (Show other bugs)
2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-08-18 06:50 EDT by Ville Skyttä
Modified: 2014-03-16 22:22 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 13:48:05 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ville Skyttä 2001-08-18 06:50:39 EDT
Description of problem:
If you're using NIS and try to (NFS) mount a filesystem from a host whose
name is found only in NIS (not files/DNS), the mounts fail because  netfs
(25) is run before ypbind (27).

One solution would of course to have the NFS server's IP address in
/etc/hosts or /etc/fstab on the client machine or in DNS, however I'm
suggesting netfs to be moved to start after ypbind (unless this has other
nasty side-effects).

Version-Release number of selected component (if applicable):
5.83-1

How reproducible:
Always
Comment 1 Frode Tennebø 2004-07-26 08:43:15 EDT
Now 3 years later, with Fedora Core 2, this is still exactly the same 
problem. And has been so for all RH/FC releases in between. 

Problem:
[root@garvin rc3.d]# cd /etc/rc3.d/
[root@garvin rc3.d]# ls -l S2*
lrwxrwxrwx  1 root root 16 Jul 16 14:47 S20random -> ../init.d/random
lrwxrwxrwx  1 root root 16 Jul 16 14:50 S24pcmcia -> ../init.d/pcmcia
lrwxrwxrwx  1 root root 15 Jul 16 14:47 S25netfs -> ../init.d/netfs
lrwxrwxrwx  1 root root 14 Jul 16 14:50 S26apmd -> ../init.d/apmd
lrwxrwxrwx  1 root root 16 Jul 19 09:05 S27ypbind -> ../init.d/ypbind
lrwxrwxrwx  1 root root 16 Jul 16 14:50 S28autofs -> ../init.d/autofs

Solution:
[root@garvin rc3.d]# mv S25netfs S29netfs

Result:
[root@garvin rc3.d]# ls -l S2*
lrwxrwxrwx  1 root root 16 Jul 16 14:47 S20random -> ../init.d/random
lrwxrwxrwx  1 root root 16 Jul 16 14:50 S24pcmcia -> ../init.d/pcmcia
lrwxrwxrwx  1 root root 14 Jul 16 14:50 S26apmd -> ../init.d/apmd
lrwxrwxrwx  1 root root 16 Jul 19 09:05 S27ypbind -> ../init.d/ypbind
lrwxrwxrwx  1 root root 16 Jul 16 14:50 S28autofs -> ../init.d/autofs
lrwxrwxrwx  1 root root 15 Jul 16 14:47 S29netfs -> ../init.d/netfs
Comment 2 Frode Tennebø 2004-08-13 04:25:11 EDT
Of course, this must also be done for rc4.d and rc5.d.
Comment 3 Chris Feist 2005-02-01 17:27:05 EST

*** This bug has been marked as a duplicate of 133333 ***
Comment 4 Red Hat Bugzilla 2006-02-21 13:48:05 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.