Bug 520067 - F11: verify-rpm shouldn't use human-readable units, perhaps
F11: verify-rpm shouldn't use human-readable units, perhaps
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: yum-utils (Show other bugs)
11
All Linux
low Severity low
: ---
: ---
Assigned To: Seth Vidal
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-08-28 04:52 EDT by "FeRD" (Frank Dana)
Modified: 2014-01-21 18:11 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-12-11 20:54:34 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description "FeRD" (Frank Dana) 2009-08-28 04:52:52 EDT
Description of problem:
While cleaning up my system after a disk surface error that caused it to hang in the middle of a software update, I received the following output from 'sudo yum verify-rpm':

--------
mono-addins.x86_64 : Addins for mono
    File: /usr/bin/mautil
        Problem:  mtime does not match
        Current:  Mon Apr 13 19:31:22 2009 (128 days, 20:03:38.690464 earlier)
        Original: Thu Aug 20 15:35:01 2009
    File: /usr/lib64/mono/gac/Mono.Addins.CecilReflector/0.4.0.0__0738eb9f132ed756/Mono.Addins.CecilReflector.dll
        Problem:  checksum does not match
        Current:  e3b0c44298fc1c149afbf4c8996fb92427ae41e4649b934ca495991b7852b855
        Original: 9d904db49c0db41dde0abf95962531e513cfafc163b61b27da3f9007c9d5c24b
                                   --------                                   
        Problem:  size does not match
        Current:  367 k
        Original: 367 k
                                   --------                                   
        Problem:  mtime does not match
        Current:  Mon Apr 13 19:31:21 2009 (128 days, 20:03:38.608718 earlier)
        Original: Thu Aug 20 15:35:00 2009
    File: /usr/lib64/mono/gac/Mono.Addins.CecilReflector/0.4.0.0__0738eb9f132ed756/Mono.Addins.CecilReflector.dll.mdb
--------

...As you can see, the middle report -- while correct -- looks rather confusing due to yum-utils' printing the file size in human-readable units. Sure, "I know what it's trying to say". But there's really no point in displaying the sizes at all, unless it's to SHOW that they differ... something that's not actually being done here.

Version-Release number of selected component (if applicable):
yum-plugin-verify-1.1.22-1.fc11.noarch

How reproducible:
Unnecessary, the issue is an implementation decision within the verify plugin.
Comment 1 James Antill 2009-09-17 10:58:11 EDT
Fixed in upstream commit: a18c124fe7f55ab4ef7bd191150f60767c6c8aa4

diff --git a/plugins/verify/verify.py b/plugins/verify/verify.py
index da2ce0b..ef38e7f 100644
--- a/plugins/verify/verify.py
+++ b/plugins/verify/verify.py
@@ -274,6 +274,10 @@ Verify packages and display data on bad verifications"""
             if problem.type == 'size':
                 cv = "%*s" % (5, base.format_number(cv))
                 ov = "%*s" % (5, base.format_number(ov))
+                if cv == ov: # ignore human units, so we can see the diff.
+                    cv = "%*s B" % (12, str(problem.disk_value))
+                    ov = "%*s B" % (12, str(problem.database_value))
+
             (hib, hie) = self._mode_except(base, 'new', problem, _verify_nnohi)
             msg("        Current:  " + hib + cv + hie)
             (hib, hie) = self._mode_except(base, 'old', problem, _verify_onohi)
Comment 2 "FeRD" (Frank Dana) 2009-09-19 02:57:04 EDT
Awesome news, thanks James!

Do we know when there will be a build available containing this fix? I just installed yum-plugin-verify-1.1.23-3.fc12.noarch from rawhide, but it doesn't seem to solve the problem yet.
Comment 3 James Antill 2009-09-20 00:58:28 EDT
I couldn't say ... esp. if you want to know when it'll be in F11. At a guess yum-utils _might_ get updated update/F12 next week ... but it might also be after F12 GA.

Personally I'd just apply the patch locally (or take the entire .py file from upstream :).
Comment 4 "FeRD" (Frank Dana) 2009-12-11 20:54:19 EST
Fedora 12's latest yum-plugin-verify-1.1.24-2.fc12.noarch fixes this:

    File: /usr/share/doc/pm-utils/README.debugging
    Tags: documentation
        Problem:  checksum does not match
        Current:  e3b0c44298fc1c149afbf4c8996fb92427ae41e4649b934ca495991b7852b855
        Original: a3d512d8dbbb2e217de592fc92c9167627b0ca8f2e3edfd668870a8576e3f571
                                   --------                                   
        Problem:  size does not match
        Current:          2433 B
        Original:         2432 B
                                   --------                                   
        Problem:  mtime does not match
        Current:  Fri Dec 11 20:50:33 2009 (128 days, 14:02:08 later)
        Original: Wed Aug  5 06:48:25 2009

Thanks, closing!

Note You need to log in before you can comment on or make changes to this bug.