Bug 520069 - OLPC dracut module not POSIX compliant
Summary: OLPC dracut module not POSIX compliant
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: dracut-modules-olpc
Version: 12
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Daniel Drake
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-08-28 09:04 UTC by Alexander Todorov
Modified: 2009-12-11 14:53 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-12-11 14:53:37 UTC


Attachments (Terms of Use)

Description Alexander Todorov 2009-08-28 09:04:07 UTC
Description of problem:

Hello, (children of the) world!
[: 48: 1: unexpected operator
/pre-mount/10olpc-boot-premount.sh: 71: -z: not found
[: 72: 0: unexpected operator
[: 85: unexpected operator


Version-Release number of selected component (if applicable):
dracut-olpc-modules-o.2.1-2.fc12

How reproducible:
always

Steps to Reproduce:
1. Boot a rawhide system with dracut and observe the screen
2.
3.
  
Actual results:
Error messages from olpc related scripts.

Expected results:
No error messages.

Additional info:
This get's captured in /var/log/boot.log as well.

From #dracut on irc:
(11,55,43) haraldh: yes, olpc have their own scripts
(11,56,10) haraldh: they should either replace dash with bash or fix their scripts to be posix compliant

Comment 1 Bug Zapper 2009-11-16 11:47:55 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 12 development cycle.
Changing version to '12'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping

Comment 2 Daniel Drake 2009-12-11 14:53:37 UTC
This was fixed a while ago


Note You need to log in before you can comment on or make changes to this bug.