Bug 520079 - Installation of fedora 12 crashes (dmraid)
Summary: Installation of fedora 12 crashes (dmraid)
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: rawhide
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Hans de Goede
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-08-28 09:48 UTC by Winfrid Tschiedel
Modified: 2009-09-21 12:35 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-09-21 12:35:35 UTC


Attachments (Terms of Use)
Traceback from the crash (259.07 KB, text/plain)
2009-08-28 09:48 UTC, Winfrid Tschiedel
no flags Details
requested log + dmraid -s -vvv before installation is confirmed (20.30 KB, application/octet-stream)
2009-09-04 14:37 UTC, Winfrid Tschiedel
no flags Details
same but after scanning devices (31.56 KB, application/octet-stream)
2009-09-04 14:42 UTC, Winfrid Tschiedel
no flags Details

Description Winfrid Tschiedel 2009-08-28 09:48:11 UTC
Created attachment 359041 [details]
Traceback from the crash

Description of problem:

It is not possible to assign new or unformatted partitions during installations on a system with SATA RAID. Note, there is currently another problem in the installer - BIOS is not automatically detected so the installer would crash while looking for storage devices, but this can be bypassed by starting dmraid manually. 


Version-Release number of selected component (if applicable):
anaconda of fedora 12 alpha

How reproducible:
always

Steps to Reproduce:
1. Install fedora 12 on a SATA RAID, activate dmraid manuall : dmraid -ay
2. Do a manual allocation of partitions
3. Make new allocation of a partition
  
Actual results:
Installer crashes

Expected results:
No crash !!!!!!!


Additional info:
In case of an unformatted partition select this partition with "EDIT" 
result : you cannot assign a mountpoint

Comment 1 Joel Andres Granados 2009-09-02 11:35:18 UTC
This bug is probably caused by the fact that the raid device was started manually.  Can you pls post the traceback of that original issue.

Comment 2 Winfrid Tschiedel 2009-09-02 12:36:43 UTC
Hi Joel,

I the case that I do not activate dmraid manually -
I have no disks to install my system. 
So there is no traceback.

Winfrid

Comment 3 Joel Andres Granados 2009-09-02 13:36:37 UTC
Then pls attach the log files /tmp/anaconda.log /tmp/storage.log /tmp/syslog /tmp/program.log.  Also attache the output of `dmraid -s -vvv`.  Attach all these files after anaconda has tried to detect your storage devices.

Comment 4 Winfrid Tschiedel 2009-09-03 07:44:00 UTC
Hi Joel,

Did you check 518971 and 519101, these issue might already contain at least some of the information you asked -
if you need still the information you asked for, I will take care tomorrow.

Winfrid

Comment 5 Hans de Goede 2009-09-03 07:54:02 UTC
(In reply to comment #4)
> Hi Joel,
> 
> Did you check 518971 and 519101, these issue might already contain at least
> some of the information you asked -
> if you need still the information you asked for, I will take care tomorrow.
> 
> Winfrid  

Winfrid, we we still need that info, and can you also please, as soon as the
welcome screen comes up (so before the "finding storage devices" wait dialog, switch to tty2 and do:
dmraid -ay -t
And paste the resulting output here.

Thanks.

Comment 6 Winfrid Tschiedel 2009-09-04 14:37:44 UTC
Created attachment 359817 [details]
requested log + dmraid -s -vvv before installation is confirmed

Comment 7 Winfrid Tschiedel 2009-09-04 14:42:41 UTC
Created attachment 359819 [details]
same but after scanning devices

Sorry I forgot the dmraid -ay -t

hope it doesn't matter -
because I succeeded installing fedora 12 with 
a manually actived dmraid

Comment 8 Hans de Goede 2009-09-07 10:00:15 UTC
Winfrid,

There have been a lot of significant changes (fixes) to the code involved in this
but since the F-12 alpha. Can you please retry with todays rawhide, using netboot.iso.

I know you cannot do a network install because we lack proxy support. What you can do is download install.img from the images directory and put it on a local http server, then point there when asked for the install tree. This will cause
anaconda to abort when it starts looking for repository information, but if we get that far, then we are passed this bug, so that does not matter.

Also please do *NOT* run dmraid your self as a workaround, if things do not work
as they should, get the log files under /tmp from the system and attach them here.

Comment 9 Hans de Goede 2009-09-21 12:35:35 UTC
I believe that the root cause of this is the same dmraid issue with single disk pdc sets as you reported in bug 509962, this dmraid issue has been fixed in rawhide 2 days ago, closing.


Note You need to log in before you can comment on or make changes to this bug.