Bug 520176 - setroubleshoot: SELinux is preventing dhclient "getcap" access on <Unknown>.
Summary: setroubleshoot: SELinux is preventing dhclient "getcap" access on <Un...
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: selinux-policy
Version: rawhide
Hardware: x86_64
OS: Linux
low
medium
Target Milestone: ---
Assignee: Daniel Walsh
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: setroubleshoot_trace_hash:28b7434f660...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-08-28 18:25 UTC by cgrim
Modified: 2009-09-02 01:41 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-08-28 18:56:31 UTC


Attachments (Terms of Use)

Description cgrim 2009-08-28 18:25:07 UTC
The following was filed automatically by setroubleshoot:

Souhrn:

SELinux is preventing dhclient "getcap" access on <Unknown>.

Podrobný popis:

SELinux denied access requested by dhclient. It is not expected that this access
is required by dhclient and this access may signal an intrusion attempt. It is
also possible that the specific version or configuration of the application is
causing it to require additional access.

Povolení přístupu:

You can generate a local policy module to allow this access - see FAQ
(http://fedora.redhat.com/docs/selinux-faq-fc5/#id2961385) Please file a bug
report (http://bugzilla.redhat.com/bugzilla/enter_bug.cgi) against this package.

Další informace:

Kontext zdroje                unconfined_u:system_r:dhcpc_t:s0-s0:c0.c1023
Kontext cíle                 unconfined_u:system_r:dhcpc_t:s0-s0:c0.c1023
Objekty cíle                 None [ process ]
Zdroj                         dhclient
Cesta zdroje                  /sbin/dhclient
Port                          <Neznámé>
Počítač                    (removed)
RPM balíčky zdroje          dhclient-4.1.0p1-8.fc12
RPM balíčky cíle           
RPM politiky                  selinux-policy-3.6.28-8.fc12
Selinux povolen               True
Typ politiky                  targeted
MLS povoleno                  True
Vynucovací režim            Enforcing
Název zásuvného modulu     catchall
Název počítače            (removed)
Platforma                     Linux (removed) 2.6.31-0.180.rc7.git4.fc12.x86_64 #1
                              SMP Wed Aug 26 16:15:07 EDT 2009 x86_64 x86_64
Počet upozornění           3
Poprvé viděno               Pá 28. srpen 2009, 20:16:26 CEST
Naposledy viděno             Pá 28. srpen 2009, 20:18:19 CEST
Místní ID                   9d8b6683-1440-4c7b-9089-5b5770aee2f1
Čísla řádků              

Původní zprávy auditu      

node=(removed) type=AVC msg=audit(1251483499.571:243): avc:  denied  { getcap } for  pid=3686 comm="dhclient" scontext=unconfined_u:system_r:dhcpc_t:s0-s0:c0.c1023 tcontext=unconfined_u:system_r:dhcpc_t:s0-s0:c0.c1023 tclass=process

node=(removed) type=SYSCALL msg=audit(1251483499.571:243): arch=c000003e syscall=125 success=no exit=-13 a0=7f91fd5ae6f4 a1=7f91fd5ae6fc a2=1 a3=30 items=0 ppid=3639 pid=3686 auid=500 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=pts0 ses=2 comm="dhclient" exe="/sbin/dhclient" subj=unconfined_u:system_r:dhcpc_t:s0-s0:c0.c1023 key=(null)


audit2allow suggests:

#============= dhcpc_t ==============
allow dhcpc_t self:process getcap;

Comment 1 cgrim 2009-08-28 18:48:34 UTC
This alert is showen to me after each login after upgrade from F11 to Rawhide.

But during update of selinux-policy-targeted package it showed this message:
  Installing     : selinux-policy-targeted-3.6.28-8.fc12.noarch                                                                                                                     libsepol.scope_copy_callback: polkit_auth: Duplicate declaration in module: type/attribute polkit_var_lib_t (No such file or directory).
libsemanage.semanage_link_sandbox: Link packages failed (No such file or directory).
semodule:  Failed!

Probably there should be some relation. Have I badly installed selinux-policy-targeted package or is that problem elsewhere?

Comment 2 Daniel Walsh 2009-08-28 18:56:31 UTC
Try

# semodule  -r polkit_auth

Should fix both problems.

Fixed in selinux-policy-3.6.28-9.fc12.noarch


Note You need to log in before you can comment on or make changes to this bug.