Bug 520191 - Unable to boot F-11-GOLD on power5 ppc
Summary: Unable to boot F-11-GOLD on power5 ppc
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: yaboot
Version: 12
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Tony Breeds
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-08-28 20:17 UTC by James Laska
Modified: 2013-09-02 06:40 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-12-22 01:09:35 UTC


Attachments (Terms of Use)
/etc/yaboot.conf (542 bytes, text/plain)
2009-08-28 20:17 UTC, James Laska
no flags Details
boot.log (11.55 KB, text/plain)
2009-09-04 19:16 UTC, James Laska
no flags Details

Description James Laska 2009-08-28 20:17:30 UTC
Created attachment 359115 [details]
/etc/yaboot.conf

Description of problem:

After a vanilla install ... yaboot refuses to boot giving the following error message.

Config file error: Token is too long near line 1 in file /etc/yaboot.conf


Version-Release number of selected component (if applicable):
 * F-11-GOLD

How reproducible:

 * /dev/sda1 - prep
 * /dev/sda2 - /boot
 * /dev/sda3 - swap
 * /dev/sdb1 - /
  
Actual results:

Elapsed time since release of system processors: 6260 mins 35 secs

Config file read, 32768 bytes
Config file error: Token is too long near line 1 in file /etc/yaboot.conf
Syntax error or read error config
Welcome to yaboot version 1.3.14 (Red Hat 1.3.14-13.fc11)
Enter "help" to get some basic usage information
boot:

Expected results:


Additional info:

 * See attached yaboot.conf used

Comment 1 Roman Rakus 2009-08-31 08:04:33 UTC
Can you please try to remove line `fstype=raw' in yaboot.conf and reinstall yaboot?

Comment 2 James Laska 2009-08-31 12:15:06 UTC
1) Removed fstype=raw from yaboot.conf
2) Reinstalled yaboot

# mkofboot -v

mkofboot: Overwrite contents of /dev/sda1 with /usr/lib/yaboot/yaboot? [y/N] y
mkofboot: Installing primary bootstrap /usr/lib/yaboot/yaboot onto /dev/sda1...
mkofboot: Installation successful
mkofboot: Installation complete.

3) Reboot ...

Elapsed time since release of system processors: 12 mins 35 secs

Config file read, 32768 bytes
Config file error: Token is too long near line 1 in file /etc/yaboot.conf
Syntax error or read error config
Welcome to yaboot version 1.3.14 (Red Hat 1.3.14-13.fc11)
Enter "help" to get some basic usage information
boot: 
: Unable to parse

Comment 3 Roman Rakus 2009-09-04 07:32:49 UTC
Can you please try http://koji.fedoraproject.org/koji/getfile?taskID=1654128&name=yaboot-1.3.14-666.fc12.ppc.rpm ? This will print a lot of debug output. There is really something very strange.

Comment 4 James Laska 2009-09-04 19:16:30 UTC
Created attachment 359840 [details]
boot.log

Attached boot log with debugging enabled

Comment 5 Roman Rakus 2009-09-07 08:36:32 UTC
Yaboot doesn't read yaboot.conf properly. It reads some kind of garbage from a disk. What fs type is /dev/sda2?

Comment 6 Roman Rakus 2009-09-07 08:38:19 UTC
And /dev/sdb1?

Comment 7 Roman Rakus 2009-09-07 11:53:00 UTC
Here are the problems:
    file_block_open - number: 03, start: 0x0006803f, length: 0x00b60000
--> ext2_open
    ext2_open - dev=/pci@800000020000002/pci@2,4/pci1069,b166@1/scsi@1/sd@5,0, part=0x003080ec (3), file_name=/etc/yaboot.conf
    ext2_open - partition offset: d007e00, end: 179007e00
    ext2_open - </pci@800000020000002/pci@2,4/pci1069,b166@1/scsi@1/sd@5,0:0>
    ext2_open - file->of_device = 017e3b00
    linux_set_blksize - bs set to 0x400
    ext2_open - ext2fs_open returned bad magic loading file 016bfad8
<-- ext2_open - -8

The number above is the partition number, which should be 2 not 3 (I hope). Can you please check if the partitions are OK?

Comment 8 James Laska 2009-09-08 12:17:20 UTC
The system is accessible from rescue-mode and the partitions all are sane.

sh-4.0# mount | grep dev.sd
/dev/sdb1 on /mnt/sysimage type ext3 (rw,relatime,errors=continue,user_xattr,acl,data=ordered)
/dev/sda2 on /mnt/sysimage/boot type ext3 (rw,relatime,errors=continue,user_xattr,acl,data=ordered)

sh-4.0# umount /mnt/sysimage/boot/
sh-4.0# e2fsck  /dev/sda2
e2fsck 1.41.4 (27-Jan-2009)
/dev/sda2: clean, 20/51200 files, 51222/204800 blocks

sh-4.0# for PATH in /mnt/sysimage/dev/pts /mnt/sysimage/dev/shm /mnt/sysimage/dev /mnt/sysimage/dev/shm /mnt/sysimage/proc /mnt/sysimage/sys /mnt/sysimage/selinux /mnt/sysimage ; do umount $PATH ; done
sh-4.0# e2fsck /dev/sdb1
e2fsck 1.41.4 (27-Jan-2009)
/dev/sdb1: clean, 31238/2223872 files, 393429/8885945 blocks

sh-4.0# mount /dev/sdb1 /mnt/sysimage
sh-4.0# mount /dev/sda2 /mnt/sysimage/boot
sh-4.0# cat /mnt/sysimage/boot/etc/yaboot.conf 
# yaboot.conf generated by anaconda

boot=/dev/sda1
init-message="Welcome to Fedora!\nHit <TAB> for boot options"

partition=2
timeout=5
install=/usr/lib/yaboot/yaboot
delay=5
enablecdboot
enableofboot
enablenetboot
nonvram
fstype=raw

image=/vmlinuz-2.6.31-0.199.rc8.git2.fc12.ppc64
	label=linux
	read-only
	initrd=/initrd-generic-2.6.31-0.199.rc8.git2.fc12.ppc64.img
	root=/dev/sdb1
	append="console=hvc0LANG=en_US.UTF-8SYSFONT=latarcyrheb-sun16 KEYTABLE=us"

Comment 9 Denise Dumas 2009-09-24 19:13:15 UTC
This is also tracked in RHEL6 BZ 523754

Comment 10 Tony Breeds 2009-09-30 04:56:11 UTC
(In reply to comment #4)
> Created an attachment (id=359840) [details]
> boot.log
> 
> Attached boot log with debugging enabled  

This log shows:
---
partitions:
    file_block_open - number: 03, start: 0x0006803f, length: 0x00b60000
---

Which means that yaboot only identifies one partition with type 0x83 (or 0xfd)
which seems very strange to me.

After booting the system into rescue mode what does fdisk -l /dev/sda show?

Comment 11 James Laska 2009-09-30 17:15:55 UTC
This is a different system, but is exhibiting the same failure.  If this is a different problem, I'm happy to open up a new bugzilla to track this.

After installation using the following partitions
=================================
 * PPC PRep - sda1
 * /boot - sda2
 * LVM physical volume - sda3 (encrypted)
 * LVM physical volume - sdb1 (encrypted)
 * LVM logical volume '/' (encrypted)

I get the following boot prompt
=================================

Elapsed time since release of system processors: 218 mins 57 secs

Config file read, 32768 bytes

Welcome to yaboot version 1.3.14 (Red Hat 1.3.14-19.fc12)
Enter "help" to get some basic usage information
boot: 
boot: 
can't get <device_type> for device: 
Please wait, loading kernel...
can't get <device_type> for device: 
:-1,/vmlinux: Unable to open file, Invalid device
boot: 
can't get <device_type> for device: 
Please wait, loading kernel...
can't get <device_type> for device: 
:-1,/vmlinux: Unable to open file, Invalid device


Booting the system into rescue mode shows
a good yaboot.conf
=================================

sh-4.0# cat /mnt/boot/etc/yaboot.conf 
# yaboot.conf generated by anaconda

boot=/dev/sda1
init-message="Welcome to Fedora!\nHit <TAB> for boot options"

partition=2
timeout=5
install=/usr/lib/yaboot/yaboot
delay=5
enablecdboot
enableofboot
enablenetboot
nonvram
fstype=raw

image=/vmlinuz-2.6.31.1-56.fc12.ppc64
	label=linux
	read-only
	initrd=/initramfs-2.6.31.1-56.fc12.ppc64.img
	root=/dev/mapper/luks-a56a0242-9c17-4ef8-aa2d-bbc8bd743ad0
	append=" LANG=en_US.UTF-8 SYSFONT=latarcyrheb-sun16 KEYTABLE=us console=hvc0"


And fdisk output
=================================
sh-4.0# fdisk -l /dev/sda

Disk /dev/sda: 36.4 GB, 36401479680 bytes
128 heads, 32 sectors/track, 17357 cylinders
Units = cylinders of 4096 * 512 = 2097152 bytes
Disk identifier: 0x18360800

   Device Boot      Start         End      Blocks   Id  System
/dev/sda1   *           1           3        4096   41  PPC PReP Boot
Partition 1 does not end on cylinder boundary.
/dev/sda2               3         103      204800   83  Linux
Partition 2 does not end on cylinder boundary.
/dev/sda3             103       17356    35334885   83  Linux
Partition 3 does not end on cylinder boundary.

Comment 12 Bug Zapper 2009-11-16 11:49:23 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 12 development cycle.
Changing version to '12'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping

Comment 13 Tony Breeds 2009-11-26 01:12:06 UTC
I think the yaboot in F-12 is okay, so we can close this right?

Comment 14 James Laska 2009-12-16 19:42:00 UTC
Indeed, let's close this out


Note You need to log in before you can comment on or make changes to this bug.