Bug 520199 - Compaq Proliant ML350 with a Promise FastTrak S150 TX4 - install exited abnormally
Summary: Compaq Proliant ML350 with a Promise FastTrak S150 TX4 - install exited abnor...
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: rawhide
Hardware: i686
OS: Linux
low
urgent
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-08-28 21:01 UTC by 35472742437j275u27u27k2
Modified: 2009-11-08 09:50 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-11-08 09:50:18 UTC


Attachments (Terms of Use)

Description 35472742437j275u27u27k2 2009-08-28 21:01:01 UTC
Description of problem: installation of Fedora 12 alpha exited abnormaly.


How reproducible: boot the Fedora 12 alpha installation dvd.

  
Actual results: when Anaconda is started, the installer gives the following error message (on the blue screen): "/usr/sbin/load-policy: error while loading shared libraries: /lib/libselinux.so.1: cannot read file data: Input/output error". This message is followed with "install exited abnormally [1/1]" and "you may safely reboot your system".


Additional info: system used is a Compaq Proliant ML350 with a Promise FastTrak S150 TX4 sata controller. Attached to it is one 250GB WD harddisk. There are no SCSI harddisks present. On the single IDE channel there is only one Pioneer DVD writer (loaded with the Fedora 12 alpha installation dvd). The server is currenty running CentOS 5.3.


[root@testserver ~]# lspci
00:00.0 Host bridge: Broadcom CNB20LE Host Bridge (rev 05)
00:00.1 Host bridge: Broadcom CNB20LE Host Bridge (rev 05)
00:01.0 PCI bridge: Digital Equipment Corporation DECchip 21152 (rev 03)
00:02.0 RAID bus controller: Promise Technology, Inc. PDC20319
(FastTrak S150 TX4) (rev 02)
00:03.0 USB Controller: NEC Corporation USB (rev 43)
00:03.1 USB Controller: NEC Corporation USB (rev 43)
00:03.2 USB Controller: NEC Corporation USB 2.0 (rev 04)
00:04.0 SCSI storage controller: Adaptec AIC-7850 (rev 03)
00:0f.0 ISA bridge: Broadcom OSB4 South Bridge (rev 4f)
00:0f.1 IDE interface: Broadcom OSB4 IDE Controller
01:04.0 SCSI storage controller: LSI Logic / Symbios Logic 53C896/897 (rev 05)
01:04.1 SCSI storage controller: LSI Logic / Symbios Logic 53C896/897 (rev 05)
01:05.0 Ethernet controller: Intel Corporation 82557/8/9/0/1 Ethernet
Pro 100 (rev 08)
01:06.0 VGA compatible controller: ATI Technologies Inc 3D Rage IIC
215IIC [Mach64 GT IIC] (rev 7a)
01:07.0 System peripheral: Compaq Computer Corporation Advanced System
Management Controller

Comment 1 Chris Lumens 2009-08-28 21:06:58 UTC
Did you run media check?  An I/O error in a place like that is frequently caused by bad media.

Comment 2 35472742437j275u27u27k2 2009-08-29 14:32:43 UTC
When I run a media check on the Proliant server, I instantly get an error. If I do the same check on three other computers, on all of them it checks out fine without a problem.

The downloaded .iso file checks out when I do a sha256sum check (219778f65cb1f897f992d87715cbe83f17255fa184ef6e1571584b9bb9160521).

I have replaced the dvd-writer from the server by a regular dvd-rom player. When I install or do a media check on Fedora 12 alpha, I get the same problems.

Fedora 12 alpha was burned on a dvdrw. I have burned it to a regular dvdr (using verify after burn). When using this dvdr to install or check, I get the same results: errors on the Proliant, no faults on any other computer.

When I do a media check on CentOS-5.3 and Scientific Linux 5.3 on the server with the dvd-writer and/or the dvd-rom player, I get no errors. Both dvd's have been burned on the same computer/dvd-writer I burned Fedora 12 alpha on.

Comment 3 Chuck Ebbert 2009-10-14 11:38:11 UTC
Can you get to the other ttys and capture the kernel log after trying to verify the install media?

Comment 4 35472742437j275u27u27k2 2009-10-15 18:26:38 UTC
I did the check on another computer. As soon as Anaconda reports that the media passed the check, I checked the other ttys.

[CTRL][ALT][F3] gives:
"mediacheck: /dev/sr0 (Fedora 12-Alpha disc ALL) PASSED"

Just for kicks, I tried the same trick on the Proliant server. I booted the installation dvd and when it "crashed", I checked the ttys.

[CTRL][ALT][F3] gives:
"17:50 INFO: Running anaconda script /usr/bin/anaconda"

[CTRL][ALT][F4] gives:
"<3>SQUASHFS error: Unable to read page, block 23962e5, size 1f1a"

Comment 5 Chuck Ebbert 2009-10-17 10:06:26 UTC
(In reply to comment #4)

> Just for kicks, I tried the same trick on the Proliant server. I booted the
> installation dvd and when it "crashed", I checked the ttys.
> 
> [CTRL][ALT][F3] gives:
> "17:50 INFO: Running anaconda script /usr/bin/anaconda"
> 
> [CTRL][ALT][F4] gives:
> "<3>SQUASHFS error: Unable to read page, block 23962e5, size 1f1a"  

There should be a bunch of error messages before that. You should be able to mount a USB stick in the shell and capture the output of the the 'dmesg' command.

Comment 6 35472742437j275u27u27k2 2009-10-21 18:04:59 UTC
None of the ttys give me a working shell.
Some display some text, others don't.
But none of them accept any input.

Comment 7 Vedran Miletić 2009-10-26 11:31:56 UTC
How about Fedora 12 Beta?

Comment 8 35472742437j275u27u27k2 2009-10-29 07:07:08 UTC
Fedora 12 Beta gives the same results as with Alpha.

Comment 9 Vedran Miletić 2009-10-29 07:23:07 UTC
Thanks for reporting back. I'm updating summary to have a bit better keywords.

Comment 10 35472742437j275u27u27k2 2009-11-07 22:17:35 UTC
I have isolated the cause of the problem: the server itself. Using a DVD player or burner results in the same problem. Not only with Fedora 12 beta, also with other distributions (verification errors etc.).

But when I test with a CD rom player, all problems are gone. It appears that the Proliant server has a problem with DVD equipment. The server has been dismantled and replaced by a more modern machine.

Comment 11 Vedran Miletić 2009-11-08 09:50:18 UTC
So it could be a BIOS bug of some kind. Let's close it as NOTABUG then.


Note You need to log in before you can comment on or make changes to this bug.