Bug 52022 - rpm (/usr/lib/rpmb) segfault
rpm (/usr/lib/rpmb) segfault
Status: CLOSED DUPLICATE of bug 50182
Product: Red Hat Linux
Classification: Retired
Component: rpm (Show other bugs)
7.1
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Jeff Johnson
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-08-18 20:12 EDT by Ed Price
Modified: 2007-04-18 12:36 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-11-10 13:06:50 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ed Price 2001-08-18 20:12:15 EDT
Description of Problem:

rpm segfaults trying to build latest rawhide XFree86.

Version-Release number of selected component (if applicable):

"rpm -qiv rpm":

Name        : rpm                          Relocations: (not relocateable)
Version     : 4.0.2                             Vendor: Red Hat, Inc.
Release     : 8                             Build Date: Sun 08 Apr 2001
06:44:02 PM EDT
Install date: Sat 26 May 2001 09:30:12 PM EDT      Build Host:
porky.devel.redhat.com
Group       : System Environment/Base       Source RPM: rpm-4.0.2-8.src.rpm
Size        : 3127541                          License: GPL
Packager    : Red Hat, Inc. <http://bugzilla.redhat.com/bugzilla>
Summary     : The Red Hat package management system.
[...]

How Reproducible: very

Steps to Reproduce:
1. rpm --rebuild [--target=i686] XFree86-4.1.0-0.9.13.src.rpm
2. 
3. 

Actual Results:

Installing XFree86-4.1.0-0.9.13.src.rpm
[Building target platforms: i686]
[Building for target i686]
Segmentation fault (core dumped)

Expected Results:

something besides a segfault. :)
(ie a successful build, unsuccessful build, error message about bad
package, error message about corrupt db, whatever...)


Additional Information:
	
the XFree86-4.1.0-0.9.13.src.rpm is from rawhide.
i reproduced the problem on two machines.
both are running redhat 7.1 with updates but fairly "stock".

i tried "rpm --rebuilddb" but it made no difference (ie that command
succeeded without a segfault, but the subsequent --rebuild of XFree86 still
segfaulted).

(gdb) core core
Core was generated by `/usr/lib/rpm/rpmb --rebuild --target i686 --
XFree86-4.1.0-0.9.13.src.rpm'.
Program terminated with signal 11, Segmentation fault.
#0  0x40126f44 in ?? ()
(gdb) where
#0  0x40126f44 in ?? ()
#1  0x401280c7 in ?? ()
#2  0x401282a8 in ?? ()
#3  0x4003a9af in ?? ()
#4  0x4003ad3b in ?? ()
#5  0x4003a2c6 in ?? ()
#6  0x4003b63a in ?? ()
#7  0x0804a5d4 in ?? ()
#8  0x0804a7bb in ?? ()
#9  0x0804b785 in ?? ()
#10 0x40174177 in ?? ()
(gdb) quit
Comment 1 Jeff Johnson 2001-08-19 11:50:35 EDT
Yup, the use of a parameterized macro in the XFree86 package
triggers a bug in rpm-4.0.2. 

Either upgrade to rpm-4.0.3, or look for a later XFree86 package
that doesn't use a parameterized macro.
Comment 2 Ed Price 2001-08-19 14:18:19 EDT
upgrading rpm (i used 2.0.3-0.91 from rawhide) fixed the problem.

thanks!

(not such an easy upgrade though... oh well.)
Comment 3 Mike A. Harris 2002-11-10 13:07:17 EST

*** This bug has been marked as a duplicate of 50182 ***

Note You need to log in before you can comment on or make changes to this bug.