Bug 520234 - cannot compile VirtualBox kendev with gcc 4.2 - segmentation fault.
Summary: cannot compile VirtualBox kendev with gcc 4.2 - segmentation fault.
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Fedora
Classification: Fedora
Component: gcc
Version: 11
Hardware: i686
OS: Linux
low
medium
Target Milestone: ---
Assignee: Jakub Jelinek
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-08-29 13:48 UTC by dmcleod
Modified: 2009-09-02 10:31 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-09-02 10:31:42 UTC


Attachments (Terms of Use)
requested file is attached. (24.93 KB, text/plain)
2009-08-29 20:50 UTC, dmcleod
no flags Details
LIsting of all packages on my system (47.21 KB, text/plain)
2009-09-02 02:00 UTC, dmcleod
no flags Details
sosreport (756.13 KB, application/x-bzip)
2009-09-02 02:02 UTC, dmcleod
no flags Details

Description dmcleod 2009-08-29 13:48:00 UTC
Description of problem:


Version-Release number of selected component (if applicable):

Virtualbox 3.04


How reproducible:

su -

/etc/init.d/vboxdrv setup



Steps to Reproduce:
1.
2.
3.
  
Actual results:



Expected results:


Additional info:

here is the log file from /var/log/vbox-install.log (attached)

bottom of log states segmentation fault in gcc.

  gcc -Wp,-MD,/tmp/vbox.11/math/gcc/.qdivrem.o.d  -nostdinc -isystem /usr/lib/gcc/i586-redhat-linux/4.4.1/include -Iinclude  -I/usr/src/kernels/2.6.29.6-217.2.16.fc11.i686.PAE/arch/x86/include -include include/linux/autoconf.h -D__KERNEL__ -Wall -Wundef -Wstrict-prototypes -Wno-trigraphs -fno-strict-aliasing -fno-common -Werror-implicit-function-declaration -fno-delete-null-pointer-checks -Os -m32 -msoft-float -mregparm=3 -freg-struct-return -mpreferred-stack-boundary=2 -march=i686 -mtune=generic -Wa,-mtune=generic32 -ffreestanding -DCONFIG_AS_CFI=1 -DCONFIG_AS_CFI_SIGNAL_FRAME=1 -pipe -Wno-sign-compare -fno-asynchronous-unwind-tables -mno-sse -mno-mmx -mno-sse2 -mno-3dnow -Iarch/x86/include/asm/mach-generic -Iarch/x86/include/asm/mach-default -Wframe-larger-than=1024 -fno-stack-protector -fno-omit-frame-pointer -fno-optimize-sibling-calls -g -pg -Wdeclaration-after-statement -Wno-pointer-sign -fwrapv -fno-dwarf2-cfi-asm -I/lib/modules/2.6.29.6-217.2.16.fc11.i686.PAE/build/include -I/tmp/vbox.11/ -I/tmp/vbox.11/include -I/tmp/vbox.11/r0drv/linux -D__KERNEL__ -DMODULE -DRT_OS_LINUX -DIN_RING0 -DIN_RT_R0 -DIN_SUP_R0 -DVBOX -DRT_WITH_VBOX -DVBOX_WITH_HARDENING -DCONFIG_VBOXDRV_AS_MISC -DRT_ARCH_X86 -DVBOX_WITH_64_BITS_GUESTS -DMODULE -D"KBUILD_STR(s)=#s" -D"KBUILD_BASENAME=KBUILD_STR(qdivrem)"  -D"KBUILD_MODNAME=KBUILD_STR(vboxdrv)"  -c -o /tmp/vbox.11/math/gcc/qdivrem.o /tmp/vbox.11/math/gcc/qdivrem.c
/tmp/vbox.11/math/gcc/qdivrem.c: In function ‘__qdivrem’:
/tmp/vbox.11/math/gcc/qdivrem.c:75: internal compiler error: Segmentation fault
Please submit a full bug report,
with preprocessed source if appropriate.
See <http://bugzilla.redhat.com/bugzilla> for instructions.
Preprocessed source stored into /tmp/ccds1rPS.out file, please attach this to your bugreport.
make[2]: *** [/tmp/vbox.11/math/gcc/qdivrem.o] Error 1
make[1]: *** [_module_/tmp/vbox.11] Error 2
make: *** [vboxdrv] Error 2

Comment 1 Jakub Jelinek 2009-08-29 15:18:13 UTC
Please provide /tmp/ccds1rPS.out, as the message asked you to do.

Comment 2 dmcleod 2009-08-29 20:50:31 UTC
Created attachment 359170 [details]
requested file is attached.

File is atached . Thanks Dennis

Comment 3 Jakub Jelinek 2009-08-31 17:38:15 UTC
What gcc NVR?  I can't reproduce with gcc-4.4.0-4.i586 nor gcc-4.4.1-2.fc11.i586.

Comment 4 dmcleod 2009-08-31 23:11:05 UTC
[dmcleod@Fedora ~]$ gcc --version
gcc (GCC) 4.4.1 20090725 (Red Hat 4.4.1-2)
Copyright (C) 2009 Free Software Foundation, Inc.
This is free software; see the source for copying conditions.  There is NO
warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.

[dmcleod@Fedora ~]$

Comment 5 dmcleod 2009-09-02 02:00:42 UTC
Created attachment 359463 [details]
LIsting of all packages on my system

Comment 6 dmcleod 2009-09-02 02:02:05 UTC
Created attachment 359464 [details]
sosreport


Note You need to log in before you can comment on or make changes to this bug.