Bug 520277 - nss-tools-3.12.3.99.3-25.fc12 and -26.fc12 not installable
Summary: nss-tools-3.12.3.99.3-25.fc12 and -26.fc12 not installable
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: nss
Version: 12
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Elio Maldonado Batiz
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-08-30 03:51 UTC by Michel Alexandre Salim
Modified: 2010-09-20 05:06 UTC (History)
3 users (show)

Fixed In Version: nss-3.12.4
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-09-20 05:06:46 UTC


Attachments (Terms of Use)

Description Michel Alexandre Salim 2009-08-30 03:51:00 UTC
Description of problem:
The two depends on libsqlite3.so() -- on 64-bit systems, libsqlite3.so()(64bit) but this is not available; sqlite only provides libsqlite3.so.0() and libsqlite3.so.0()(64bit)

Version-Release number of selected component (if applicable):
nss-tools-3.12.3.99.3-25.fc12
nss-tools-3.12.3.99.3-26.fc12

How reproducible:
Always

Steps to Reproduce:
1. yum install nss-tools (this is -25 right now)
2. download nss and nss-tools -26 from Koji and attempt to install
  
Actual results:
Error because of unsatisfied dep on libsqlite3.so()

Expected results:
Should install

Additional info:

Comment 1 Elio Maldonado Batiz 2009-08-31 03:39:39 UTC
The problem was detected in releases 25 and 26 though it was introduced earlier. I traced back to release 18 and that was the last where the nss-tools installed okay. nss-tools "inherits" the sqlite dependency from nss. As part of the split I moved a couple of patches, one called nss-nolocalsql.patch, to nss-softokn where it rightfully belongs. Eventually I removed those patches from nss.spec.The problem is that in nss we still compile all sources (though we don't ship duplicate libraries or headers) and I should have kept the patches here as well. 

Restoring the nss-nolocalsql.patch allows me to install nss-util without problems. The fix should be in nss-3.12.3.99.3-29.fc12, see
http://koji.fedoraproject.org/koji/buildinfo?buildID=129934

Comment 2 Michel Alexandre Salim 2009-09-01 23:02:10 UTC
Fix confirmed to work, thanks! Has this been upstreamed?

Comment 3 Elio Maldonado Batiz 2009-09-02 00:11:55 UTC
yes, upstream is correct as in 3.12.4. These patches will no longer be needed when we update to 3.12.4.

Comment 4 Bug Zapper 2009-11-16 11:49:54 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 12 development cycle.
Changing version to '12'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping

Comment 5 Fedora Admin XMLRPC Client 2010-09-07 20:55:08 UTC
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.


Note You need to log in before you can comment on or make changes to this bug.