Bug 520280 - Multiple Monitor Support does not recognize Mattrox G450
Summary: Multiple Monitor Support does not recognize Mattrox G450
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-mga
Version: 12
Hardware: i686
OS: Linux
low
high
Target Milestone: ---
Assignee: Adam Jackson
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: card_mgag400 (G450)
: 475750 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-08-30 06:37 UTC by Paul F. Almquist
Modified: 2018-04-11 09:01 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-12-05 06:31:32 UTC


Attachments (Terms of Use)
output of dmesg (30.60 KB, text/plain)
2009-11-11 18:28 UTC, Paul F. Almquist
no flags Details
f12 log file (30.83 KB, text/plain)
2009-11-11 18:30 UTC, Paul F. Almquist
no flags Details
f12 Xorg.0.log file (31.32 KB, text/plain)
2009-11-11 18:31 UTC, Paul F. Almquist
no flags Details
f12 log file from test using f8 xorg.conf (23.81 KB, text/plain)
2009-11-11 18:33 UTC, Paul F. Almquist
no flags Details
f8 dmesg output (23.10 KB, text/plain)
2009-11-11 18:34 UTC, Paul F. Almquist
no flags Details
f8 log file (40.48 KB, text/plain)
2009-11-11 18:35 UTC, Paul F. Almquist
no flags Details
f8 xorg.conf file (1.61 KB, text/plain)
2009-11-11 18:35 UTC, Paul F. Almquist
no flags Details

Description Paul F. Almquist 2009-08-30 06:37:59 UTC
Description of problem:
System Settings -> Display -> Multiple Monitor displays message:
"This module is only for configuring systems with a single desktop spread across multiple monitors.  You do not appear to have this configuration."

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.
2.
3.
  
Actual results:
No multiple monitor support provided.

Expected results:
Multiple monitor support provided.

Additional info:
Using KDE (kdebase-4.3.0-1.fc12.i686, etc)
From Xorg.0.log:
(--) PCI:*(0:1:0:0) 102b:0525:102b:0641 Matrox Graphics, Inc. MGA G400/G450 rev 130, Mem @ 0xe4000000/33554432, 0xe6000000/16384, 0xe7000000/8388608, BIOS @ 0x???????
...
(==) Using default built-in configuration (30 lines)
(==) --- Start of built-in configuration ---
        Section "Device"
                Identifier      "Builtin Default mga Device 0"
                Driver  "mga"



This or a related problem has existed since Fedora 9 so I'm still using Fedora 8 to have multiple monitor support.  I had submitted a bug report on system-config-display on F9.  I don't find it in F12alpha live CD.

Comment 1 Matěj Cepl 2009-11-05 17:14:40 UTC
Since this bugzilla report was filed, there have been several major updates in various components of the Xorg system, which may have resolved this issue. Users who have experienced this problem are encouraged to upgrade their system to the latest version of their packages (at least F12Beta, but even better if the very latest versions).

Please, if you experience this problem on the up-to-date system, let us now in the comment for this bug, or whether the upgraded system works for you.

If you won't be able to reply in one month, I will have to close this bug as INSUFFICIENT_DATA. Thank you.

[This is a bulk message for all open Fedora Rawhide Xorg-related bugs. I'm adding myself to the CC list for each bug, so I'll see any comments you make after this and do my best to make sure every issue gets proper attention.]

Comment 2 Paul F. Almquist 2009-11-09 11:29:36 UTC
I have upgraded to F12beta with all updated packages as of 0400 9Nov2009.  Still no change with this multiple monitor issue so I'm back to using my F8 system.  Any other info I can give you?

Comment 3 Matěj Cepl 2009-11-09 13:58:00 UTC
Please attach your X server config file (/etc/X11/xorg.conf, if available), output of the dmesg command, and X server log file (/var/log/Xorg.*.log) to the bug report as individual uncompressed file attachments using the bugzilla file attachment link below.

We will review this issue again once you've had a chance to attach this information.

Thanks in advance.

Comment 4 Paul F. Almquist 2009-11-11 18:28:50 UTC
Created attachment 369076 [details]
output of dmesg

Comment 5 Paul F. Almquist 2009-11-11 18:30:21 UTC
Created attachment 369077 [details]
f12 log file

Comment 6 Paul F. Almquist 2009-11-11 18:31:02 UTC
Created attachment 369078 [details]
f12 Xorg.0.log file

Comment 7 Paul F. Almquist 2009-11-11 18:33:20 UTC
Created attachment 369079 [details]
f12 log file from test using f8 xorg.conf

xorg.conf file from f8 was tried with f12.  X failed.  see error reported near end of log file

Comment 8 Paul F. Almquist 2009-11-11 18:34:22 UTC
Created attachment 369080 [details]
f8 dmesg output

Comment 9 Paul F. Almquist 2009-11-11 18:35:12 UTC
Created attachment 369082 [details]
f8 log file

Comment 10 Paul F. Almquist 2009-11-11 18:35:51 UTC
Created attachment 369083 [details]
f8 xorg.conf file

Comment 11 Bug Zapper 2009-11-16 11:50:05 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 12 development cycle.
Changing version to '12'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping

Comment 12 Vedran Miletić 2009-11-28 09:11:24 UTC
*** Bug 475750 has been marked as a duplicate of this bug. ***

Comment 13 QuentinM 2010-02-03 10:21:52 UTC
I have encountered this issue with f12 and MGA G550 when attempting to configure the system for dualhead operation. By default I get cloned displays and no recognition of the second head. After creating and editing an xorg.conf for dualhead operation, the second head doesn't initialize and I get the same error message:

(EE) MGA(1): Unable to map BAR 0.  Invalid argument (22) 

is found in the xorg logfile

On searching the net, it appears that a bug giving the same error message has been found and fixed previously. 
See http://www.mccaughan.org.uk/g/log/index.html 

A patch for an earlier version of the driver can be found here:

http://launchpadlibrarian.net/19618287/mga-driver-3.patch

I'm afraid I'm out of my depth, but when comparing the patch with the current source, the patch amendments don't seem to be there.

Hope this is of some assistance?

Comment 14 Bug Zapper 2010-11-04 10:18:20 UTC
This message is a reminder that Fedora 12 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 12.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '12'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 12's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 12 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping

Comment 15 Bug Zapper 2010-12-05 06:31:32 UTC
Fedora 12 changed to end-of-life (EOL) status on 2010-12-02. Fedora 12 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.


Note You need to log in before you can comment on or make changes to this bug.