Bug 52031 - poor handling of non-existant disk during installation
Summary: poor handling of non-existant disk during installation
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Public Beta
Classification: Retired
Component: anaconda   
(Show other bugs)
Version: roswell
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Matt Wilson
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-08-19 09:52 UTC by greg hosler
Modified: 2007-04-18 16:36 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-08-21 18:27:33 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description greg hosler 2001-08-19 09:52:50 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.78 [en] (X11; U; Linux 2.4.7-2smp i686; Nav)

Description of problem:
I have a MO drive, and the MO was not installed.
The normal device for the MO is /dev/sdd (4th scsi).
All prior installations ignored this "non -existant" drive.
During installation, after package selection, I get the popup error
message:

	Error: /tmp/sdd No Medium Found
	[cancel] [retry]

and on console 1, I see teh error message:

	Error opening /tmp/sdd: No medium found
	80

Note that I did not specify any partition on /dev/sdd
for installation. It should not have been concerning itself whether it
could open the device or not. Since the device is a removeable drive, it
especially should not care...

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. configure a scsi chain w/ a removeable device. (possibly a scsi zip
drive would give this error as well)
2. do installation.
3. Error shows up shortly after package selection, and before 1st package
gets installed.
	

Actual Results:  unnecessary error message box. I clicked cancel, and
installation progressed. (note that clicking <cancel> is not obvious in as
much as you really do not want to cancel the installation. Perhaps the
button should hev been [ignore] - be that as it may, the error message
really should not be displayed, esp when the device is a removeable.


Expected Results:  no message box.

Additional info:

did not used to happen in any prior beta, or any prior RH installer.

Comment 1 Matt Wilson 2001-08-20 15:15:07 UTC
Please run this on Alt+F2:

PYTHONPATH=/usr/lib/anaconda python -c "import isys; isys.driveIsRemovable('sdd')"



Comment 2 greg hosler 2001-08-20 15:30:55 UTC
at which point of the installation is the above python string runnable.
(hopefully before installation starts ? I'm not desireing to reinstall, just at
the moment, but I can if need be...)



Comment 3 Matt Wilson 2001-08-20 15:33:42 UTC
as soon as you get to anaconda in either text or gui mode, you don't need to
reinstall.

Oh, and run this instead:

PYTHONPATH=/usr/lib/anaconda python -c "import isys; print
isys.driveIsRemovable('sdd')"


(note the addition of 'print')




Comment 4 greg hosler 2001-08-20 15:50:11 UTC
Attribute Error: driveIsRemoveable


Comment 5 Matt Wilson 2001-08-20 15:56:43 UTC
s/driveIsRemoveable/driveIsRemovable/

(you have an extra 'e')




Comment 6 Glen Foster 2001-08-20 19:22:22 UTC
We (Red Hat) should really try to fix this before next release.

Comment 7 greg hosler 2001-08-20 23:18:48 UTC
The python print statements prints the following:

1



Comment 8 Matt Wilson 2001-08-21 18:27:28 UTC
bug found; fixed in cvs.



Note You need to log in before you can comment on or make changes to this bug.