Bug 520355 - setroubleshoot: SELinux is preventing the system-config-s from using potentially mislabeled files (/root).
Summary: setroubleshoot: SELinux is preventing the system-config-s from using pot...
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: selinux-policy
Version: rawhide
Hardware: x86_64
OS: Linux
low
medium
Target Milestone: ---
Assignee: Daniel Walsh
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: setroubleshoot_trace_hash:dfd2eb17e8c...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-08-31 05:24 UTC by Renich Bon Ciric
Modified: 2009-08-31 14:10 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-08-31 14:10:59 UTC


Attachments (Terms of Use)

Description Renich Bon Ciric 2009-08-31 05:24:29 UTC
The following was filed automatically by setroubleshoot:

Summary:

SELinux is preventing the system-config-s from using potentially mislabeled
files (/root).

Detailed Description:

SELinux has denied system-config-s access to potentially mislabeled file(s)
(/root). This means that SELinux will not allow system-config-s to use these
files. It is common for users to edit files in their home directory or tmp
directories and then move (mv) them to system directories. The problem is that
the files end up with the wrong file context which confined applications are not
allowed to access.

Allowing Access:

If you want system-config-s to access this files, you need to relabel them using
restorecon -v '/root'. You might want to relabel the entire directory using
restorecon -R -v '/root'.

Additional Information:

Source Context                system_u:system_r:sambagui_t:s0-s0:c0.c1023
Target Context                system_u:object_r:admin_home_t:s0
Target Objects                /root [ dir ]
Source                        system-config-s
Source Path                   /usr/bin/python
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           python-2.6.2-2.fc12
Target RPM Packages           filesystem-2.4.30-2.fc12
Policy RPM                    selinux-policy-3.6.28-9.fc12
Selinux Enabled               True
Policy Type                   targeted
MLS Enabled                   True
Enforcing Mode                Enforcing
Plugin Name                   home_tmp_bad_labels
Host Name                     (removed)
Platform                      Linux (removed)
                              2.6.31-0.190.rc8.fc12.x86_64 #1 SMP Fri Aug 28
                              18:51:58 EDT 2009 x86_64 x86_64
Alert Count                   1
First Seen                    Mon 31 Aug 2009 12:19:02 AM CDT
Last Seen                     Mon 31 Aug 2009 12:19:02 AM CDT
Local ID                      ce08d5f2-34c1-4788-a62c-5e85eb93f4ff
Line Numbers                  

Raw Audit Messages            

node=(removed) type=AVC msg=audit(1251695942.635:107): avc:  denied  { search } for  pid=2543 comm="system-config-s" name="root" dev=dm-0 ino=90114 scontext=system_u:system_r:sambagui_t:s0-s0:c0.c1023 tcontext=system_u:object_r:admin_home_t:s0 tclass=dir

node=(removed) type=SYSCALL msg=audit(1251695942.635:107): arch=c000003e syscall=4 success=no exit=-2 a0=1d4a550 a1=7fffd2d04410 a2=7fffd2d04410 a3=7fffd2d041a0 items=0 ppid=2542 pid=2543 auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=4294967295 comm="system-config-s" exe="/usr/bin/python" subj=system_u:system_r:sambagui_t:s0-s0:c0.c1023 key=(null)


audit2allow suggests:

#============= sambagui_t ==============
allow sambagui_t admin_home_t:dir search;

Comment 1 Daniel Walsh 2009-08-31 14:10:59 UTC
Fixed in selinux-policy-3.6.29-2.fc12.noarch


Note You need to log in before you can comment on or make changes to this bug.