Bug 52041 - problems with cd burning on ide cdrw on same ide channel of HD
Summary: problems with cd burning on ide cdrw on same ide channel of HD
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: kernel   
(Show other bugs)
Version: 7.3
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Arjan van de Ven
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-08-19 16:26 UTC by giulioo
Modified: 2007-04-18 16:36 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-08-24 12:58:46 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description giulioo 2001-08-19 16:26:24 UTC
Description of problem:
If your system is IDE, and you have the main HD on the same ide channel of 
an ide-cdrw, and burn cd with cdrecord, then system will stay frozen for 
about 1min at "Blanking PMA, TOC, pregap", then ok, then freeze again 
at "Fixating...", then ok.

For frozen, I mean you cannot do ls, ps, any command; these commands 
simply don't return until cdrecord has finished that phase. You cannot 
telnet into, access samba shares, ...


Version-Release number of selected component (if applicable):
kernel-2.4.7-2
cdrecord-1.10-3

How reproducible:
Always

Steps to Reproduce:
1. The system has main ide HD on same ide-channel of ide-cdrw (ie: hda & 
hdb)
2. use cdrecord to burn an ide-cdrw
3.
	

Actual Results:  System hangs for up to 1min in certain burning phases.

Expected Results:  System should be responsive, a minimal degraded 
performance could be accepted

Additional info:

I performed this test on roswell 2.4 kernel, because I have a serious 
problem on a 2.2.19 kernel, and wanted to see if this was solved.
On 2.2.19, since I enabled linux software mirroring on hda+hdc, I can no 
longer burn cd without users complaining the system is frozen.
With mirroring, both ide channels are taken and you have not the option to 
put the ide-cdrw on the other channel (which solves the problem).

Comment 1 Glen Foster 2001-08-20 19:25:20 UTC
This defect is considered SHOULD-FIX for Fairfax.

Comment 2 Arjan van de Ven 2001-08-24 12:58:41 UTC
IDE is not scsi. If an IDE device gets a command, it holds the bus until it's
done..... normally you don't notice because a command takes a short time (read
or write). However CD finalize taks upto a minute or so.

Recommendation: buy a $25 hpt370 IDE controller if you don't spare channels
on the motherboard.

Comment 3 Arjan van de Ven 2001-08-24 16:52:48 UTC
Closing as it's not a bug


Note You need to log in before you can comment on or make changes to this bug.