Bug 520432 - Updating to clutter-1.0.4-1.fc12.x86_64 breaks link for /usr/lib64/libclutter-glx-1.0.so.0
Summary: Updating to clutter-1.0.4-1.fc12.x86_64 breaks link for /usr/lib64/libclutter...
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: clutter
Version: rawhide
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Itamar Reis Peixoto
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-08-31 13:44 UTC by Tom London
Modified: 2009-08-31 14:30 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-08-31 14:30:15 UTC


Attachments (Terms of Use)

Description Tom London 2009-08-31 13:44:03 UTC
Description of problem:
Updating to rawhide clutter breaks empathy:

[tbl@tlondon ~]$ empathy
empathy: error while loading shared libraries: libclutter-glx-1.0.so.0: cannot open shared object file: No such file or directory
[tbl@tlondon ~]$ 

Here is what /usr/lib64/libclutter* was prior to update (and working empathy):
[root@tlondon lib64]# ls -l *clutter*
lrwxrwxrwx. 1 root root     27 2009-08-31 06:25 libclutter-glx-1.0.so.0 -> libclutter-glx-1.0.so.0.2.0
-rwxr-xr-x. 1 root root 855080 2009-08-14 09:45 libclutter-glx-1.0.so.0.2.0
lrwxrwxrwx. 1 root root     28 2009-07-30 15:53 libclutter-gtk-0.10.so.0 -> libclutter-gtk-0.10.so.0.0.0
-rwxr-xr-x. 1 root root  42696 2009-07-29 16:00 libclutter-gtk-0.10.so.0.0.0
[root@tlondon lib64]# 


And here it is after:
Running Transaction
  Updating       : clutter-1.0.4-1.fc12.x86_64                              1/2 
  Cleanup        : clutter-1.0.2-1.fc12.x86_64                              2/2 

Updated:
  clutter.x86_64 0:1.0.4-1.fc12                                                 

Complete!
[root@tlondon lib64]# ls -l *clutter*
lrwxrwxrwx. 1 root root     27 2009-08-31 06:33 libclutter-glx-1.0.so.0 -> libclutter-glx-1.0.so.0.2.0
-rwxr-xr-x. 1 root root 855400 2009-08-30 08:41 libclutter-glx-1.0.so.0.0.4
lrwxrwxrwx. 1 root root     28 2009-07-30 15:53 libclutter-gtk-0.10.so.0 -> libclutter-gtk-0.10.so.0.0.0
-rwxr-xr-x. 1 root root  42696 2009-07-29 16:00 libclutter-gtk-0.10.so.0.0.0
[root@tlondon lib64]# 

Manually "fixing" the symbolic link for libclutter-glx-1.0.so.0 to point at libclutter-glx-1.0.so.0.0.4 "fixes for me"

Version-Release number of selected component (if applicable):
clutter-1.0.4-1.fc12.x86_64

How reproducible:
Everytime

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 Owen Taylor 2009-08-31 14:30:15 UTC
There was a screwup in upstream maintenance, so the version went backwards between 1.0.2 and 1.0.4.

When ldconfig ran in the %post scriplet, both the new and old were installed, it saw the so.0.2.0 (from the old version) as being newer, and left the symlink pointing to that.

I'm going to WONTFIX this:

 - I don't want to deviate from upstream on the shared library numbering
 - Clutter 1.0 was never in an actual Fedora release
 - The next library installed will re-run ldconfig and fix the symlinks - after today or so nobody will likely ever hit this problem. Because it's unlikely that in a larger upgrade Clutter will be the last library updated.


Note You need to log in before you can comment on or make changes to this bug.