Bug 520439 - Customers not able to post updates/ add attachments to ticket created via email (product field required)
Summary: Customers not able to post updates/ add attachments to ticket created via ema...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Issue-Tracker
Classification: Retired
Component: Issue Comments
Version: MR16
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Lisa Lu
QA Contact: Nicole Yancey
URL:
Whiteboard:
Depends On:
Blocks: 532706
TreeView+ depends on / blocked
 
Reported: 2009-08-31 14:02 UTC by Nicole Yancey
Modified: 2009-11-18 12:56 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-11-14 13:31:45 UTC


Attachments (Terms of Use)

Description Nicole Yancey 2009-08-31 14:02:40 UTC
Description of problem: Customers not able post updates and attachments to ticket if issue created via email.  Product is a required field and customers not allowed to update product field.  


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. Login to http://cspserver2.app.dev.redhat.com/issue-tracker as customer (e.g. Glen Johnson)
2. Go to Users- change email address to your test email address
3. Go to email - send email to tao@enterprise.webqa.redhat.com
4. Go back to Issue Tracker (logged in as Glen Johnson)
5. Search for ticket created in step 3
6. Add comment or attachment to ticket
7. Message- type field is required
8. Update type field......
9. Add comment or attachment.......hit Commit Data
9. Message - Please update product field

You can test with Issue 202456 and 202461.  Login as Glen Johnson in http://cspserver2.app.dev.redhat.com/issue-tracker



  
Actual results: User not able to update product field.  And they are not able to add comments/ attachments to ticket.


Expected results: User should be able to post comments/ attachments to ticket.  But not sure if they should be able to update product field.  


Additional info: Not sure if user should be able to update product field after ticket has been created.  Need to talk to Lisa on best solution.

Comment 2 Lisa Lu 2009-08-31 16:20:28 UTC
Nicole, 

Fix is on dev:
 http://cspserver2.app.dev.redhat.com

thanks,
Lisa

Comment 3 Nicole Yancey 2009-08-31 16:40:41 UTC
verified on http://cspserver2.app.dev.redhat.com/issue-tracker

Comment 4 Nicole Yancey 2009-09-16 20:27:08 UTC
verified on http://enterprise.webqa.redhat.com/issue-tracker

Comment 5 Nicole Yancey 2009-09-21 13:21:30 UTC
verified on https://enterprise.stage.redhat.com/issue-tracker

Comment 6 Nicole Yancey 2009-09-30 14:28:19 UTC
Released to Production 9/26
Reverted back to MR13-IT 9-28 due to customers receiving private notifications

Comment 7 Nicole Yancey 2009-11-03 21:27:27 UTC
verified on http://cspserver2.app.dev.redhat.com/issue-tracker

Comment 8 Nicole Yancey 2009-11-09 13:16:53 UTC
verified on https://enterprise.stage.redhat.com/issue-tracker/

Comment 9 Nicole Yancey 2009-11-14 13:31:45 UTC
Released to Production 11/14


Note You need to log in before you can comment on or make changes to this bug.