Bug 520450 - screen often hangs after resizing window and exiting vim
Summary: screen often hangs after resizing window and exiting vim
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: screen
Version: 11
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Miroslav Lichvar
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-08-31 14:37 UTC by Stefan Assmann
Modified: 2009-10-29 08:06 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-10-29 08:06:36 UTC


Attachments (Terms of Use)

Description Stefan Assmann 2009-08-31 14:37:19 UTC
Description of problem:
I've had it a few times now that my screen session crashed after I resized the window and tried to quit vim afterwards. The window will freeze and still display the vim screen. This does not always happen, sometimes it happens after I let the screen alone for a while.

ps fax |grep screen
15152 ?        Ss     0:00 /usr/bin/SCREEN -S topright -c /home/sassmann/.screenrc.topright
17075 ?        S      0:00 xterm -geometry 135x40+2550+0 -e /home/sassmann/bin/screen.topright.sh
17077 pts/62   Ss+    0:00  \_ /bin/bash /home/sassmann/bin/screen.topright.sh
17084 pts/62   S+     0:00      \_ screen -S topright -c /home/sassmann/.screenrc.topright
17085 ?        Zs     0:02          \_ [screen] <defunct>

I tried to get a backtrace for debugging but I failed. I ran screen inside of gdb but when screen crashed I couldn't get back in gdb. I the tried to attach to the defunct process but that failed as well.
(gdb) attach 17085 (run as root)
Attaching to process 17085
ptrace: Operation not permitted.
(gdb) 

If you have an idea how I could provide a backtrace let me know.

Version-Release number of selected component (if applicable):
screen-4.0.3-13.fc11.x86_64

How reproducible:
sometimes

Steps to Reproduce:
1. run screen inside xterm
2. edit some (probably big? not sure) file in vim
3. resize window (I usually switch to fullscreen)
4. try to close vim with :qa

Actual results:
screen is shown as defunct in process list

Expected results:
screen should run on fine

Comment 1 Enrico Scholz 2009-09-12 10:46:49 UTC
dup of bug #515055 (which points to two upstream patches)?

Comment 2 Miroslav Lichvar 2009-09-25 12:45:20 UTC
Please try screen-4.0.3-15.fc12 from rawhide to see if the patches help.

Comment 3 Stefan Assmann 2009-10-28 08:04:00 UTC
Hi Miroslav,

I've updated to F12 and tried screen-4.0.3-15.fc12. It didn't crash so far but it what happened once is that the window took like 1-2 minutes to become responsive after a resize. I guess you can close this for now and I'll reopen if I have more input for you. Thanks!


Note You need to log in before you can comment on or make changes to this bug.