Bug 520455 - NetworkManager 0.7.1 won't detect HUAWEI K3565
Summary: NetworkManager 0.7.1 won't detect HUAWEI K3565
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: NetworkManager
Version: 11
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Dan Williams
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-08-31 14:48 UTC by David
Modified: 2009-10-08 15:19 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-10-08 14:49:30 UTC


Attachments (Terms of Use)
output from udevmonitor while plugging in device (6.35 KB, text/plain)
2009-08-31 14:48 UTC, David
no flags Details
last 500 lines of /var/log/messages (43.95 KB, text/plain)
2009-09-01 20:53 UTC, David
no flags Details
ouput from lsusb (539 bytes, text/plain)
2009-09-01 20:55 UTC, David
no flags Details

Description David 2009-08-31 14:48:59 UTC
Created attachment 359272 [details]
output from udevmonitor while plugging in device

Description of problem:

NetworkManager 0.7.1 won't detect Vodafone Mobile Connect, Model HUAWEI K3565. The device is recognised according to output from dmesg and from /var/log/messages when connecting, even ran udevmonitoring all seems to switch device to /dev/ttyUSB0 and /dev/ttyUSB1. 

I can get this to connect with a fresh install of Fedora 11 on a vm, the only difference I can see is that my home drive on my laptop is encrypted using lucks.

Version-Release number of selected component (if applicable):

NetworkManager 0.7.1

How reproducible:

Always on encrypted /home partition
  
Actual results:

NetworkManager does not detect device

Expected results:

NetworkManager should detect device and allow me to configure connection options

Additional info:

See forum thread for more info, http://forums.fedoraforum.org/showthread.php?t=229148

Comment 1 Niels Haase 2009-08-31 23:18:01 UTC
Thanks for filling this bug. Can you please add your /var/log/messages after you try to connect to 3G. Also please attach the output of lsusb. Thank you.

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

Comment 2 David 2009-09-01 20:53:57 UTC
Created attachment 359448 [details]
last 500 lines of /var/log/messages

Comment 3 David 2009-09-01 20:55:50 UTC
Created attachment 359449 [details]
ouput from lsusb

Comment 4 David 2009-09-11 14:34:29 UTC
any news on this as this is quite important to me. Even just letting me know it works in F12 would be good. Could this be a simple timing issue?

Comment 5 David 2009-09-19 11:51:45 UTC
After a fresh install of Fedora 11 still using a encrypted partition all seems to work. For reference I am using Linux hawk 2.6.30.5-43.fc11.x86_64 #1 SMP Thu Aug 27 21:39:52 EDT 2009 x86_64 x86_64 x86_64 GNU/Linux. If you need more information just ask.

Comment 6 David 2009-09-24 11:33:46 UTC
I seem to have the same Issue again the device is recognised by the kerneal and the hal but Network Manager seems not to notice the device. 

Here is the out put of lshal -m:

12:23:38.232: computer_power_supply_battery_BAT1 property battery.voltage.current = 12502 (0x30d6)
12:23:43.107: usb_device_ffffffff_ffffffff_noserial added
12:23:43.136: usb_device_ffffffff_ffffffff_noserial_0 added
12:23:43.162: usb_device_ffffffff_ffffffff_noserial_0 removed
12:23:43.168: usb_device_ffffffff_ffffffff_noserial removed
12:23:50.947: usb_device_12d1_1003_noserial added
12:23:50.971: usb_device_12d1_1003_noserial_if0 added
12:23:51.039: usb_device_12d1_1003_noserial_if2 added
12:23:51.061: usb_device_12d1_1003_noserial_if1 added
12:23:51.138: usb_device_12d1_1003_noserial_if3 added
12:23:51.175: usb_device_12d1_1003_noserial_if1_serial_usb_0 added
12:23:51.870: usb_device_12d1_1003_noserial_if0_serial_usb_0 added
12:23:56.276: computer property info.named_locks.org.freedesktop.Hal.Device.SystemPowerManagement.exclusive removed
12:23:56.276: computer property info.named_locks.org.freedesktop.Hal.Device.SystemPowerManagement.locked removed
12:23:56.277: computer property info.named_locks.org.freedesktop.Hal.Device.SystemPowerManagement.dbus_name removed
12:23:56.277: computer property info.named_locks removed
12:23:56.277: computer interface_lock_released org.freedesktop.Hal.Device.SystemPowerManagement by :1.62 (0 lockers)
12:23:56.479: computer property info.named_locks.org.freedesktop.Hal.Device.SystemPowerManagement.exclusive = false (new)
12:23:56.483: computer property info.named_locks.org.freedesktop.Hal.Device.SystemPowerManagement.dbus_name = {':1.62'} (new)
12:23:56.485: computer property info.named_locks.org.freedesktop.Hal.Device.SystemPowerManagement.locked = true (new)
12:23:56.486: computer property info.named_locks = {'org.freedesktop.Hal.Device.SystemPowerManagement'} (new)
12:23:56.487: computer interface_lock_acquired org.freedesktop.Hal.Device.SystemPowerManagement by :1.62 (1 lockers)
12:23:56.499: computer property info.named_locks.org.freedesktop.Hal.Device.SystemPowerManagement.exclusive removed
12:23:56.499: computer property info.named_locks.org.freedesktop.Hal.Device.SystemPowerManagement.locked removed
12:23:56.499: computer property info.named_locks.org.freedesktop.Hal.Device.SystemPowerManagement.dbus_name removed
12:23:56.499: computer property info.named_locks removed
12:23:56.500: computer interface_lock_released org.freedesktop.Hal.Device.SystemPowerManagement by :1.62 (0 lockers)
12:23:56.568: computer property info.named_locks.org.freedesktop.Hal.Device.SystemPowerManagement.exclusive = false (new)
12:23:56.569: computer property info.named_locks.org.freedesktop.Hal.Device.SystemPowerManagement.dbus_name = {':1.62'} (new)
12:23:56.571: computer property info.named_locks.org.freedesktop.Hal.Device.SystemPowerManagement.locked = true (new)
12:23:56.574: computer property info.named_locks = {'org.freedesktop.Hal.Device.SystemPowerManagement'} (new)
12:23:56.575: computer interface_lock_acquired org.freedesktop.Hal.Device.SystemPowerManagement by :1.62 (1 lockers)
12:23:56.588: computer property info.named_locks.org.freedesktop.Hal.Device.SystemPowerManagement.exclusive removed
12:23:56.588: computer property info.named_locks.org.freedesktop.Hal.Device.SystemPowerManagement.locked removed
12:23:56.588: computer property info.named_locks.org.freedesktop.Hal.Device.SystemPowerManagement.dbus_name removed
12:23:56.588: computer property info.named_locks removed
12:23:56.588: computer interface_lock_released org.freedesktop.Hal.Device.SystemPowerManagement by :1.62 (0 lockers)
12:24:00.653: computer property info.named_locks.org.freedesktop.Hal.Device.SystemPowerManagement.exclusive = false (new)
12:24:00.656: computer property info.named_locks.org.freedesktop.Hal.Device.SystemPowerManagement.dbus_name = {':1.62'} (new)
12:24:00.657: computer property info.named_locks.org.freedesktop.Hal.Device.SystemPowerManagement.locked = true (new)
12:24:00.658: computer property info.named_locks = {'org.freedesktop.Hal.Device.SystemPowerManagement'} (new)
12:24:00.659: computer interface_lock_acquired org.freedesktop.Hal.Device.SystemPowerManagement by :1.62 (1 lockers)
12:24:00.667: computer property info.named_locks.org.freedesktop.Hal.Device.SystemPowerManagement.exclusive removed
12:24:00.667: computer property info.named_locks.org.freedesktop.Hal.Device.SystemPowerManagement.locked removed
12:24:00.667: computer property info.named_locks.org.freedesktop.Hal.Device.SystemPowerManagement.dbus_name removed
12:24:00.667: computer property info.named_locks removed
12:24:00.667: computer interface_lock_released org.freedesktop.Hal.Device.SystemPowerManagement by :1.62 (0 lockers)

If this is due to a timing issue with the kernel or network-manager then can we please get this fixed for F12.

Comment 7 David 2009-10-07 22:18:46 UTC
I have found out what the problem is. I have a small hack to allow VirtualBox to see my USB devices. I add the following line to my /etc/fstab:

none                   /sys/bus/usb/drivers    usbfs   devgid=502,devmode=664  0 0

As soon as I commented out the line and rebooted I could use the dongle via NM.

Comment 8 Dan Williams 2009-10-08 14:49:30 UTC
Huh, thanks for finding out what the issue is.  VirtualBox 3 has been screwing up the kernel's device tree for a while and it's good to know the workaround.  In any case, this is a bug with VirtualBox (as you've found) since it's munging around with kernel private data structures and thus completely breaking sysfs, which is kernel ABI.  Thanks for the investigation!

Comment 9 David 2009-10-08 15:19:19 UTC
Yeah it appears that more recent versions of VirtualBox now see the USB devices attached to the computer. You can use there filter option to attache specific devices to specific VMs.


Note You need to log in before you can comment on or make changes to this bug.