Bug 520457 - Install crashes on machine with SATA disk
Summary: Install crashes on machine with SATA disk
Keywords:
Status: CLOSED DUPLICATE of bug 518971
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: rawhide
Hardware: i686
OS: Linux
low
medium
Target Milestone: ---
Assignee: Anaconda Maintenance Team
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-08-31 15:03 UTC by Jim Haynes
Modified: 2009-08-31 21:52 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-08-31 21:52:04 UTC


Attachments (Terms of Use)
saved anaconda report (61.15 KB, text/plain)
2009-08-31 15:03 UTC, Jim Haynes
no flags Details
dmesg output after installation crash (29.53 KB, text/plain)
2009-08-31 15:05 UTC, Jim Haynes
no flags Details

Description Jim Haynes 2009-08-31 15:03:31 UTC
Created attachment 359275 [details]
saved anaconda report

Description of problem: Attempting to install F12 alpha
Machine is HP d530 tower with one hard drive on first IDE controller, CD ROM
drive on 2nd IDE controller, SATA hard drive on SATA0 connector.  Installation
fails during disk discovery.  Attached are anaconda log and dmesg output.


Version-Release number of selected component (if applicable):


How reproducible:  always


Steps to Reproduce:
1.Boot from CD ROM and try to install
2.
3.
  
Actual results:


Expected results:


Additional info:Fedora 10 install CD works correctly.  Fedora 11 install CD
fails to report the SATA disk at all, but does not crash

Comment 1 Jim Haynes 2009-08-31 15:05:10 UTC
Created attachment 359276 [details]
dmesg output after installation crash

Comment 2 Chuck Ebbert 2009-08-31 20:36:04 UTC
AttributeError: 'StorageDevice' object has no attribute 'partedDisk'

Comment 3 Chris Lumens 2009-08-31 21:52:04 UTC

*** This bug has been marked as a duplicate of bug 518971 ***


Note You need to log in before you can comment on or make changes to this bug.