Bug 520502 - IPA Server --setup-dns should require the Installer to provide at least one DNS forwarder
Summary: IPA Server --setup-dns should require the Installer to provide at least one D...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: freeIPA
Classification: Retired
Component: ipa-server
Version: 2.0
Hardware: All
OS: Linux
high
high
Target Milestone: ---
Assignee: Rob Crittenden
QA Contact: Chandrasekar Kannan
URL:
Whiteboard:
Depends On:
Blocks: 431020
TreeView+ depends on / blocked
 
Reported: 2009-08-31 19:57 UTC by Jenny Severance
Modified: 2015-01-04 23:40 UTC (History)
6 users (show)

Fixed In Version: freeipa-2.0.0-1.fc15
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed:


Attachments (Terms of Use)

Description Jenny Severance 2009-08-31 19:57:29 UTC
Description of problem:
After installation of IPA server with integrated DNS, the machine can no longer resolve any outside hosts.  --setup-dns should require the user to supply at least one DNS forwarder and set it up for the user.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 Martin Nagy 2009-09-03 09:35:50 UTC
Commited to master: 4e5a68397a102f0be193470257ed331baf57dc3c

Comment 2 Michael Gregg 2009-09-08 22:40:17 UTC
As of 9-8-09 this seems to be working:

From named.conf:
	forward first;
	forwarders {
		10.14.63.2;
	};

Testing it:
[root@iparhel5-vma ~]# ping wiki.idm.lab.bos.redhat.com
PING wiki.idm.lab.bos.redhat.com (10.16.78.150) 56(84) bytes of data.
64 bytes from wiki.idm.lab.bos.redhat.com (10.16.78.150): icmp_seq=1 ttl=60 time=154 ms

additional info, resolv.conf:
search dsdev.sjc.redhat.com
nameserver 10.14.1.147

Closed as verified


Note You need to log in before you can comment on or make changes to this bug.